Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a motherboard with SATA AHCI enabled, and I need to disable it to run Memtest86+ (because Window's built-in RAM diagnostic tool isn't worth a barrel of warm snot), and because the Memtest developers are too lazy to fix the bootloader problem. Fine, I know how to do that.

The problem is, I, in a moment of insanity driven by the fact that I work with hardware RAID cards all the time, felt the need to enable the onboard RAID. In retrospect, this was stupid: the onboard raid is a joke, but I'm stuck with it.

My question is, if I disable AHCI am I going to lose the RAID information? I haven't been able to find a definitive yes or no anywhere, and I'm not in the mood to find out the hard way.

EDIT: The motherboard is a Gigabyte GA-EP45-UD3P

EDIT2: People need to stop telling me to boot off a live CD. My optical drives are both SATA, and with AHCI enabled, Memtest86 stalls permanently at the "Loading......................" stage. This is the whole problem.

The USB key thing is a good idea, but the Floppy thing? Does anyone still have a floppy drive? I have an old external, but I can't be bothered to buy disks.

EDIT3: So, usb key. Worked for about 4 hours trying to make a Vista-bootable USB key (never done it, or needed to do it before, but thought I'd better myself), which was a micro-epic that culminated in me, drunk and frustrated, with a usb key that had been formatted, diskpart'd, and bootsect'd about 20 times, to no avail. Threw it out the window.

Took a fresh key, made it linux bootable (had to download the tools, so it took 5 minutes), installed the linux version, and it booted like a charm. Goddamn it.

Memtest86+ didn't work as well as I'd hoped: I couldn't localize the bad module exactly, and I ended up having to do the "RAM-shuffle" after all, but it did throw errors much faster than the crappy Windows version.

I'm planning on de-RAIDing the system this weekend, so when I get my new image made, I'll disable AHCI and see if it kills the RAID, just for the sake of experiment.


Turns out there was bad RAM AND bad slots. Not sure what the hell happened there, but it explains why I was never able to localize the problem. Installed new RAM and new Mobo, and hasn't had a problem since.

share|improve this question
... why didn't you run memtest from a livecd?? – quack quixote Apr 15 '10 at 14:30
btw, this sounds like any real answer will be specific to the RAID chipset on the motherboard, so might as well tell us now what it is. – quack quixote Apr 15 '10 at 14:32
@quack quixote: You can't. It won't boot from CD while AHCI mode is enabled. That's the whole point. – Satanicpuppy Apr 15 '10 at 14:41
Tried the USB option (or any other option) yet? – CJM Apr 16 '10 at 8:56
@satanicpuppy: ah. sorry, that you were using SATA optical drives was not clear to me; with the stuff about RAID in there, i thought you were trying to boot memtest off a SATA HDD. this really should've been two separate questions to avoid confusing the AHCI-RAID and AHCI-Memtest issues. – quack quixote Apr 16 '10 at 16:31
up vote 1 down vote accepted

Create a bootable USB disk, and then run the Memtest86+ pre-compiled EXE for USB disks.

share|improve this answer

You can run Memtest86+ form a bootable CD, Floppy or USB key. None of which should require disabling AHCI to boot from.

If you have to disable AHCI to boot from these devices you've got bigger problems than possibly bad RAM (probably a defective motherboard).

You should be able to disable AHCI or RAID and then re-enable without losing settings/data. If you're extra paranoid, perhaps unplug the drives before disabling it.

share|improve this answer
The default memtest86+ wont boot from AHCI-controlled SATA optical drives - nothing wrong with the OPs PC at all - it's purely a (well known) memtest problem... – CJM Apr 15 '10 at 15:11
Unplugging the disk drive and changing mobo to IDE should work - but seems a little too much work compared to USB solution IMHO. – CJM Apr 15 '10 at 15:13
Weird, I guess we've never gone back to booting Memtest from a CD since before we swtiched to SATA optical drives, we just got in the habit of using a bootable USB drive long before that. :) Good to know. – Ƭᴇcʜιᴇ007 Apr 16 '10 at 21:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .