Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been working on setting up VPN connectivity to our office location. We bought a Cisco WRV210 which have a builtin VPN server. Cisco has some software QuickVPN, which is not as quick and easy as I had thought. I've had mixed experiences on different machines with connecting. Instead I configured an IPSec VPN tunnel following a guide from TheGreenBow here

I followed their instructions and tried out an evaluation of their software, and VPN connection should be working ok. I'm able to do RDP to a machine on the network (using IP address, not machine name) and ping the router etc.

What I'm trying to solve are two things:

It's not like I'm "really" on the network. Or at least I'm restricted to some degree when going through the VPN. I can't access a machine on the network using machine name, only IP. I can't ping a machine, but the router just fine. Could this be that something is not set up properly? If so, I can ofcourse supply additional information.

Second, when I log onto the VPN, I would really like my outgoing connection to go through the internet connection of the remote location. Basically if I connect to the VPN I want my outgoing IP to be that of the remote location's (needed for some IP resctrictions on some of our servers). At a previous work location it worked like this when we connected to our office VPN over PPTP and the builtin windows VPN client.

I'm not a huge expert on the topic, so any hints will be appreciated.

share|improve this question

1st Question:

The basic reason is that an IPsec tunnel is for IP protocols only. There are some non-IP protocols that you may use without realizing it. So, you can expect TCP and UDP and ICMP protocols to work. Non-IP protocols like Windows uses for workgroup stuff, and AppleTalk should not be expected to work over an IP tunnel. If there is a DNS server inside the private network, and your client is configured to use it (maybe as an alternate), then machine names may be usable that way.

2nd Question:

I would think that the VPN would redirect your outgoing connection too. Is that a config option? Look at what your default gateway is with and without the VPN operating.

share|improve this answer
Okay, I guess it makes sense that I only have access to IP protocol. But is there not a way to enable these upper layers/protocols? With the VPN client TheGreenBow I'm only able to set alternate DNS/WINS server but I guess that won't help me much. My default gateway is unchanged. I also looked into my routing tables which showed the same. I also tried adding another routing table to change my gateway that way, but was unsuccesfull without at the same time disconnecting the connection. – Xorandor Apr 16 '10 at 7:08
I also just realised another thing. When I connect to the remote location over VPN my local machine access the remote machines with an IP on a different subnet. For testing I set my remote location to and my machine has IP I've tried setting my "VPN Client Address" in the VPN client but I can't set it to one on the same subnet as the remote location since that causes me not to be able to connect to remote machines at all. Could this have something to do with it as well? – Xorandor Apr 16 '10 at 9:34
That Greenbow document advises: "Usually, VPN Client IP address should not belong to the remote LAN subnet." – Jamie Cox Apr 16 '10 at 12:30
I'm not familiar with your particular VPN software. Does it create an additional (virtual) network connection? You can check with "ipconfig" at the Windows command prompt. – Jamie Cox Apr 16 '10 at 12:39
Yes, I also get warnings if I try using the same subnet. But was just a thought. But it doesn't create a new network connection. I can choose to specify a VPN Client Address, which will then be the IP I use to access the remote network. But someone else directed me to this which suggest the possibility to force all traffic through the remote gateway. But the router won't allow me to set the router setting as described. Just get an message saying "Unacceptable first value, 0 is reserved." – Xorandor Apr 16 '10 at 13:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .