Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got Windows 7. However, I'm now unable to connect to the internet.

Doing the diagnosis gives me these:

  1. There might be a problem with the driver for the Local Area Connection Adapter
  2. The Local Area Connection 2 Adapter is disabled

How do I resolve those?

These are the things I've tried:

  1. In cmd do ipconfig /renew
  2. In Device Manager, go to Network Adapter. (I don't see any red exclamation marks)
share|improve this question
You can try the troubleshooter. Those things are often quiet good at finding out what's wrong. Also some laptops have a physical switch for such things. And I've also seen one that disabled the wired LAN connection when running on battery. – Joey Apr 15 '10 at 22:25

Go here

Control Panel ---> Network and Internet --> Network Connections (search for it)

and enable the Local Area Connection 2 Adapter.

enter image description here

Choose LAN 2 instead of Himachi

share|improve this answer
thank you very much. However can you explain me why did Windows auto turn LAC Adapter off? Because I've never touch it - I'm just a normal user, then after I reboot my computer it turn into "disabled" and, thanks to your guide I solved it. – user113694 Jan 15 '12 at 2:49
@Blaster I have no Idea, maybe a software did it. – HackToHell Jan 15 '12 at 14:56

When you go to 'Network Connections' and see all of your adapters listed, is your LAN Adapter 'Enabled' or 'Disabled'? If it is disabled, right click it and click 'Enable'.

Also make sure your ethernet cable is plugged in tightly.

share|improve this answer
Hi th3dude19, all the LAN adapters that I have is enabled. (there is no pointing down black arrows). Yes my cable is plugged in tightly. Thanks, Tee – teepusink Apr 15 '10 at 22:24
The cable doesn't have anything to do with the network adapter being reported as disabled. Those are still two different things. – Joey Apr 15 '10 at 22:24
Well, if you read the question, the OP has 2 LANs being reported. Only LAN 2 was being reported as disabled. Never know. – th3dude Apr 16 '10 at 0:01

firstly check, ethernet cable is plugged in tightly.after that connectivity of cable with router if cabling connection is ok update your nic driver after enable your network adapter after that restore your lan setting automaticaly complete this process 100% your computer connect to internet.

share|improve this answer

If Local Area Connection 2 is a VPN adapter and LAC1 is a hardware adapter then this is a pretty common issue with VPN software where is doesn't release from the hardware NIC correctly.

If this is the case, go to device manager (right click "Computer" and go to Properties and then click "Device Manger" in the left task pane). Uninstall the hardware NIC. Once it is gone then click on "Action" and then "Scan for Hardware Changes". This will detect and re-add your hardware NIC. It will probably recieve "Local Area Connetion 3" as it's name (unless there are other NICs already). This will reset whatever release the VPN software messed up.

If this isn't the case and you have multiple hardware NICs, for more clarification, you may want to provide the different adapters and their expected configuration.

If Local Area Connection 2 is your wireless - look for a physical switch or toggle via Fn+F# key to enable it.

share|improve this answer

protected by Community Apr 14 '12 at 22:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.