Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to enable the FTP service in the preferences (File Sharing->Options->Share Files and Folders Using FTP) the check box enables and then disables again. The console is giving me the message :

16/04/2010 12:14:20 com.apple.coreservicesd[51] sh: launchctl: command not found

This indicates to me that it can't find the launchctl executable

launchctl is present in the folder /bin

/bin is set in the PATH variable for sh and bash shells and also in the ~/.MacOSX/environment.plist

How can I fix this so that my preferences can find this so that I can enable the FTP service.

I have since removed my environment.plist file, and this has made no difference.

share|improve this question

If you run /bin/launchctl you should get a prompt saying launchd%. If you don't it's quite likely your installed copy of launchctl is corrupted - if this is the case you can try an "Archive and Install" to re-install Mac OS X without touching your user folder.

share|improve this answer

You may want to check

file /System/Library/CoreServices/coreservicesd

that is the actual command run from com.apple.coreservicesd plist.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .