Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicates:
Make grub keep its default boot under kernel updates
Aesthetically editing grub.cfg

I'm running a dual boot configuration on my laptop using Ubuntu 10.04b and Windows 7 Home Premium.

Windows 7 was the original OS and I added a 'side by side' installation of Ubuntu. Ubuntu, however, shows up first on the list. I'd like to change this order and make Windows 7 first, followed by Ubunutu, then all of the recovery boots after that.

Any help on how this is done?

share|improve this question

marked as duplicate by heavyd, quack quixote Apr 16 '10 at 16:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I'd give you +2 if I could for the fact that you have a Steelers avatar. :D –  codeLes Apr 16 '10 at 13:34
1  
The question is not exactly the same, but the answer is. –  heavyd Apr 16 '10 at 13:48
    
It is a duplicate in that the end result is the same (as @heavyd mentions above). But the question is asked from the perspective of someone it seems doesn't even know that GRUB is at the center of the issue. So it seems more of a newbish question and I think the answers can be provided in that light as well. That's just my input. –  codeLes Apr 16 '10 at 14:02
    
Hah, thanks for the 'newbish' comment. But honestly, I'm not very familiar with boot managers. –  th3dude Apr 16 '10 at 14:09
    
@th3dude19 no offense intended by that. I do think that this is a bit of a simpler question in essence since it doesn't come out of the gate as a GRUB question. I think that will be a good addition to the answer seeking community. –  codeLes Apr 16 '10 at 14:35
show 2 more comments

2 Answers 2

You'll have to edit your grub.cfg file. here you'll find a good answer for this question.

P.S.: I don't really know about this but I guess this could be evaluated as duplicate.

share|improve this answer
    
It is almost a duplicate, but the essence of this question is almost independent of editing grub manually. I suppose that could also be found out by reading down the answers of the other questions, but it might be a bit misleading to someone who just wants to edit the ordering/default OS without prior knowledge of the technologies involved. –  codeLes Apr 16 '10 at 13:33
add comment

I found this thread with a quick Google search and a couple times they refer to startupmanager. I've never used it but Download Squad has a write up on it here.

Startup Manager, or SUM provides an easier way to edit your GRUB menu. You can find SUM in the Synaptic package manager or by typing sudo apt-get install startupmanager into a terminal window.

Once it's installed, you can access Startup Manager from the System -> Administration menu. The utility lets you change the default operating system, adjust the screen resolution of the GRUB menu, and even alter the background and text colors. You can adjust the countdown timer, set a password, or alter a number of other settings. And there's fairly little risk of messing up your boot menu beyond all repair.

Prior to the current version of grub it was quite simple to update a config file and I used to do that. You can still update it in a similar way but it is a bit more convoluted.

Hope this is helpful.

share|improve this answer
    
StartupManager basically sounds like it's tweaking the Grub variables in /etc/default/grub (tho setting background/text colors might actually rewrite one of the /etc/grub.d scripts). i think i tried SUM once and it didn't work at all (as in, wouldn't even run). i've always found the GUI configurators less fine-grained than i like so i prefer going directly to the config files. –  quack quixote Apr 16 '10 at 16:16
    
@quackQ I agree in general. I've only ever updated the config files myself. After finding this tool I gave it a try at just setting the default OS to my Windows partition. Worked. Until I updated my Ubuntu and it no longer was set... had to go in again... strange behavior. –  codeLes Apr 19 '10 at 20:01
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.