Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm looking for a wireless adapter for my new PC. My requirements are:

  • it supports 802.11n
  • it is cheap (under 30 USD)
  • it has good, open source Linux drivers (will work "out of the box")
  • preferably USB, but PCI is okay too

I found the Panda Wifi (b/g/n) 150Mbps Wireless-N (802.11n) USB Adapter. It says there is Linux support. However, I want to make sure there are open source drivers included with the Linux kernel. Does anyone know what the chipset for this adapter is? What driver it would use?

share|improve this question
    
I'm not sure what Linux u use, but for Ubuntu, thake a look there help.ubuntu.com/community/WifiDocs/WirelessCardsSupported –  Ye Lin Aung Apr 16 '10 at 15:44
    
@mgpyone: I generally use Ubuntu, but I want a device with drivers in the mainline Linux kernel so it will work with all distros. –  Zifre Apr 16 '10 at 15:47
    
Except some well-known brand(Linksys,NetGear,SMC), Ubuntu can't detect that USB Adapter automatically. the best is a fully supported card like Atheros chipsets that can be put into monitor mode :) –  Ye Lin Aung Apr 16 '10 at 15:54
1  
@mgpyone this is potentially incorrect. The chipset matters, not the brand. –  Broam Apr 16 '10 at 16:23

5 Answers 5

up vote 2 down vote accepted

I found where they sell them in a 2 pack on amazon here. There's one review that goes into some detail about how it didn't work with Fedora or OSX, as well as the chipset which if you do decide to go for it should allow you to find the drivers. However, at a glance, not being able to find a web page for whoever makes these, and the negative review i'd have to give it a pass. The company selling them does respond to the review, but it looks like you'll have to build your own kernel if you even want a chance at this working.

The chipset they state is an RT3070.

share|improve this answer

I could not find information about this device anywhere other than Amazon (all Google hits were just clones of the information on Amazon), so as such I would be EXTREMELY hesitant to recommend purchasing it until you know at least the device's USB IDs so you can check for a driver properly.

share|improve this answer

I bought this adapter from Amazon for my Fedora 13 Linux machine. They have Windows, Mac and Linux drivers on their web site. The seller (Panther Networks) gave the detailed instructions to compile and install the Linux driver on my Fedora 13 machine when I asked for it.

My brother wanted to get a Wifi adapter to his vintage G4 iBook running Mac OS X 10.4 and I tried to install the latest Mac driver from their web site but it didn't work. I asked the seller for help. He gave me another version Mac driver and the adapter worked right away after I installed the driver.

share|improve this answer

Update 4/29/2012 I have to eat crow on this one. Two things: 1) I tried the Panda again this morning, and it works fine. Ubuntu 12.04. This seems to indicate that this unit is plug and play. 2) As part of the Amazon sale, I received and email from Panda with an email address for tech support. Before got the unit working, I sent them strongly worded email and got a prompt and professional response asking for basic troubleshooting information (is the led blinking, run lsusb and ifconfig and forward output to support. Right after I set the response email, I got the unit to work, so I can't tell you anything more about the support, but FYI the lsusb returned -- Bus 001 Device 002: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter


I purchased the Panda Wifi (b/g/n) 150Mbps Wireless-N (802.11n) USB Adapter from Amazon this week. I hope this answers some questions and saves some heartache.

The supplied driver disk is labeled. "RT2070&3x7x_v1.8" — My Ubuntu 11.10 and new 12.04 failed to detect it. No "plug and play" as reported in Amazon reviews.

To test, I installed it in a Windows Vista machine. I had to run the install program from the disk - Windows did not automatically detect and install. It works fine. In device manager the driver is listed as rt2870.sys version "3.01.08.0000" by Ralink Technology, and shows two hardware ids: USB\Vid_148f&Pid_3070&REV_0101 and USB\Vid_148f&Pid_3070 I guess this means this is a Ralink rt3070 chipset, using the rt2870 driver?

For Linux, on the supplied driver disk is file DPO_RT3X7X_LinuxSTA_V2[1].3.0.4_20100604.tar.bz2.

I am no bithead, but I un-tarred the file and opened the readme, which seems to give some reasonable instructions on how to MAKE the driver from the source code files provided. I am about to embark on that voyage. I am starting with the wikipedia article on MAKE (Software).

If you want plug and play, this is not for you.

The tiny user manual supplied does not mention Linux or Mac. It does have a website. This is a lousy site, but you can download drivers, if you can determine which one you need.

share|improve this answer

I looked up the model number w/ Google. No chipset information was returned. My guess is that it's Ralink or Realtek, but you'll have to buy one to find out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.