Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As a Systems Admin I have seen this issue repeatedly and it drives me crazy. Basically the problem occurs when you open My Documents or My Computer (Windows Explorer) there is a big delay ranging from 5-25 seconds before it actually opens and shows the content. Sometimes the problem continues with each subfolder you open. The problem is most common when disconnected from the network and when you have mapped drives.

The most common solution for this problem is to disconnect any mapped drives or printers that are discconected/not reaachable. I have also heard that turning off "Automatically search for network folders and printers" can solve this issue but I have yet to see this work.

Does anyone know of any other work arounds for this?

share|improve this question

5 Answers 5

up vote 4 down vote accepted
+50

I was found this knowledge base article which supplied a hotfix that corrected the issue. I also found out this fix is included in XP SP3. Thanks for everyones suggestions.

Edit: This did not ssolve all cases, I alsop found out this issue is also often caused by the WIA server. Stopping and disabling it will fix it.

share|improve this answer
2  
You should have originally said that you were on XP SP2. It would have saved us some trouble. –  harrymc Aug 9 '10 at 12:27
    
Sorry, like I stated in the original questions I have seen this on a lot of computers and did not put together that it was SP2 exclusive. –  ITGuy24 Aug 13 '10 at 16:04

I experience this a lot as well. It has to do with indexing network directories. If you have a network with hundreds of GB of storage, you will see this often. In XP, it's a bug, and I know Vista and 7 work much better with indexing files. I usually kill the dialog box and open it again. Slow, but it almost always works to get the access I need. I don't find the need to actually disconnect the drives as you say. One other thing that I found helps is always having these directories open for faster access and the ability to transfer files independent of apps that need to save/open. Good luck.

share|improve this answer

I had this problem when one of document icons or shell extensions was registered on network drive. Check in registry under HKEY_CLASSES_ROOT if some of registered dll is on mapped drive or on \server\share\some.dll

Also check solution from this question

share|improve this answer

To find out what's going on, use Process Monitor, filter by process name explorer.exe, then look for an operation with a 5-25 second time (should be one of the columns).

share|improve this answer

This is almost always caused by either hard coded DNS, Network shortcuts in My Network Places, Network applications on the start Menu etc.

The default behavior for XP on drive mappings is to attempt to re-connect the drive mappings for what seems to be forever.

Try this:

  • Run gpedit.msc
  • Select Administrative Templates -> System -> Logon -> Always wait for the network at computer startup and logon
  • set to Enabled

Microsoft's help explains:

If you disable or do not configure this setting, Windows does not wait for the network to be fully initialized and users are logged on with cached credentials. Group Policy is applied asynchronously in the background.

Note: If you want to guarantee the application of Folder Redirection, Software Installation, or roaming user profile settings in just one logon, enable this setting to ensure that Windows waits for the network to be available before applying policy.

It must therefore be enabled to avoid background processing that might slow Explorer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.