Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way to run a VM in Fusion that starts when the machine does, but I can then access via Remote Desktop (Windows) or ssh (Linux) rather than by opening the Fusion app, starting the VM, and then connecting however I'd prefer (rdp/ssh)?

I know this is possible with VMware Server for both Linux and Windows.

share|improve this question

2 Answers 2

up vote 5 down vote accepted

I found a couple answers elsewhere.

Quoting from my first source:

  1. You may or may not want to add the location of vmrun to your default path. I chose not to as I will mostly be interacting with vmrun through shell scripts.

  2. To Launch the virtual machine named VA-LAMP.vmx which is located in the standard virtual machine directory enter the following command into the Terminal app.

/Library/Application\ Support/VMware\ Fusion/vmrun -T fusion start /Users/USERNAME/Documents/Virtual\ Machines.localized/VA-LAMP.vmwarevm/VA-LAMP.vmx nogui

To make this a command to launch the headless terminal from a file on the desktop just open text edit and enter the following text

#!/bin/bash /Library/Application\ Support/VMware\ Fusion/vmrun -T fusion start /Users/USERNAME/Documents/Virtual\ Machines.localized/VA-LAMP.vmwarevm/VA-LAMP.vmx nogui

Save the file as plain text to the desktop as headless.command

Now to make it executable fire up the terminal application and type

chmod +x $HOME/Desktop/headless.command

And the second:

To enable it you need to run the following on your console: defaults write com.vmware.fusion fluxCapacitor -bool YES

share|improve this answer
1  
I think that defaults write com.vmware.fusion fluxCapacitor -bool YES is only necessary/available in VMWare Fusion 2. In version 3, that option was removed, much to the chagrin of some users. However, the first set of instructions you posted worked just fine for me in version 3 on my Mac. –  Paul D. Waite Mar 14 '11 at 17:20
1  
@Paul, confirming that defaults write... is not required. I'm running vmrun without no problem, without the defaults... command. –  amateur barista Dec 12 '13 at 19:29

I create an example here for my own convenience: https://github.com/AlexanderAllen/lamp.

This assumes you have vmrun somewhere in your $PATH.

share|improve this answer
1  
Please besides showing the link copy the script here. The link can stop functioning in the future and in addition the script is very short. –  pabouk Dec 12 '13 at 22:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.