Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a PC with a hard drive that's divided into two partitions, one for Windows 7 and one for Ubuntu. I primarily use Windows 7 and occasionally (once a week) use Ubuntu.

When I boot up my computer, I usually get taken to a boot menu that includes about 5 different options: 3 are for Ubuntu's configurations, one's for swap, and the forth is for Windows 7. Then after I select Windows 7 or Ubuntu from this menu, I get taken to another menu that again asks me for Windows 7 or Ubuntu. This time, there's only 2 options, Windows 7 and Ubuntu. Each of these menus has a 30-second timeout before proceeding with the default action of booting into Ubuntu. So, if I ever turn my computer on without actually sitting in front of it for a few minutes, it boots into Ubuntu.

I'm trying to figure out what I need to do so I can first get rid of the 2 boot menus. And if possible, I'm looking for help changing my boot options so that Windows 7 will boot by default (even with the boot menu wait of about 30 seconds).

My hard drive's partitions are laid out like this:

  • Windows 7 (C partition)
  • Multimedia (D partition, I just use this for backup/non-OS stuff)
  • Ubuntu (home directory)
  • Swap

Is there any other information I need to provide?

share|improve this question
    
Although this might not solve your entire question, take a look at this other question: superuser.com/questions/102692/… –  heavyd Apr 16 '10 at 19:51
add comment

1 Answer

First off, are you sure you have a boot setting for 'swap' ? That's extremely bizarre. Maybe you have it set to bootable (you can change this in gparted, and if you don't know how I'd be happy to help).

The second menu sounds like you installed 'wubi.' You should look through your installed programs in Windows 7 and see if its installed. Is the ubuntu you boot into if you select Windows 7 then ubuntu the same ubuntu you get by default? If it is, then Windows 7 has a bootloader I don't know about. (This is entirely possible, I rarely boot into 7).

To change the default boot on the first screen (which is almost certainly GRUB), you just need to change a setting in the grub config file.

In Ubuntu, press alt+f2 to bring up Run box. Type gksu gedit /etc/default/grub. Enter your password, and an editor should pop up. The third or first line should say something like GRUB_DEFAULT=0. Change this to whatever windows seven is, counting down the list (remember to start at zero!).

When you're done, you'll need to update grub. Bring up a terminal from the applications menu -> accessories. Type sudo update-grub, enter your password, and wait for it to finish.

You should be good, then. Reboot your computer, and hopefully your troubles are gone!

share|improve this answer
    
Firstly, I want to address the Wubi issue and then head over to the grub options. The wubi actually was installed on a prior version of Windows 7 and I had to reinstall my Windows and after I had done so, the wubi menu still appeared but inside of Windows, there's no traces of the wubi install, any help? (And I'll work on the grub setting as soon as I get another computer so I can read the instructions) –  Muhammad Apr 27 '10 at 7:23
    
You can modify the Windows 7 boot menu by running msconfig (type in the start menu search box. In the tab that says 'boot', you should be able remove the old Wubi option. –  stillinbeta Apr 27 '10 at 18:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.