Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using Apache Web Server for a while now and one thing I have noticed is that outside of my computer I can not access it.

I use my Apache server for PHP development on my computer, but I would like to access stuff I have made outside of my computer. I am on a linksys router network. I usually run it of http://localhost/ or http://127.0.0.1/.

I IPCONFIGED my computer and got

192.168.1.105 so I went there with my browser and got the page just fine.

I tried doing this on another computer on the same network but it didn't work.

How do I fix this?

Sorry about the bad wording. I am in ah hurry

Information you might need to know:

Server: Apache 2.2 Operating System: Windows 7 ULTIMATE

share|improve this question

migrated from stackoverflow.com Apr 16 '10 at 20:38

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 2 down vote accepted

Adelec is correct, you need to setup the port forwarding on your router. In addition, apache needs to be configured to accept requests from remote connections. You modify this setting in the primary apache config file, httpd.conf. Look for 'Deny from all' in the file, change it to 'Allow from all' (read the comments in the file, you only want to do this for the main web root).

share|improve this answer
    
Also, if you have a firewall running on your web development computer, you might need to allow Apache to accept incoming connections. –  Nathaniel Apr 16 '10 at 23:34

You need to open the HTTP port (80) on the server, then if you need to go through an external network, you will have to set the router to forward the HTTP 80 to that server (192.168.1.105)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.