Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 32bit on a 3.2ghz Pentium D with 2gb RAM and a 1TB SATA hard drive.

My system was running as fast as it ever has until I installed Visual Studio and Virtual PC a few days ago. Ever since - regardless of whether either application has been running the system has been running incredibly slowly.

For example flash video plays jumpily, 3D games that used to run fine are now unplayable and even the smallest amount of multitasking makes the system unusable.

I'm confident there is no virus or other such things present following scans in safemode and I'm fairly confident I've made no other changes to my system.

Any ideas - I've run out of things to try!

share|improve this question
add comment

2 Answers

Installing either may have left a background task running (an updater perhaps) that gobbles up resources. You could check the Task Manager or Process Explorer to see if your CPU or memory is being used while it should be idle.

share|improve this answer
add comment

Your PC is rather low spec for Visual Studio 2008 - you need more than 2GB of RAM for it to behave nicely (and a better processor). What you might have running after the install is the .NET Runtime Optimization Service - this will run when the dotNET framework is updated (or installed with Visual Studio) and for a time may have an impact on performance, especially on your PC. Combine this with an aggressive anti-virus which may be scanning everything the optimizer does, and you could see things grind to a halt (until the optimizer is done, then it won't run again).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.