Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i was using gnome-mount to automount drives but in lucid it was removed. So is there any alternatives in lucid except editing fstab and programs that do so?

Gnome-mount is a program which mounts disks using the same facilities as when mounting a disk as a normal user through Nautilus. There is no need to setup mountpoints or filesystems. This is particularly interesting if you want to use the automatically created mountpoints instead of manually specifying them for each disk.

share|improve this question
up vote 2 down vote accepted

Even if there is no gnome-mount there should still be gvfs-mount

$ gvfs-mount --help
  gvfs-mount [OPTION...] - mount <location>

Help Options:
  -h, --help               Show help options

Application Options:
  -m, --mountable          Mount as mountable
  -d, --device             Mount volume with device file
  -u, --unmount            Unmount
  -s, --unmount-scheme     Unmount all mounts with the given scheme
  -l, --list               List
  -i, --detail             Show extra information for List and Monitor
  -o, --monitor            Monitor events

And as for the need to set up mountpoints manually via /etc/fstab, are you sure you didn't do something to break the functionality that came with gnome? This shouldn't require manual intervention.

share|improve this answer
Well i think you misunderstood me. I dont want to edit fstab and set mount points. Because i if do so mounting/unmounting from nautilus will not work correct. In 9.10 i was able to add "gnome-mount -p Data" to startup applications and everything was perfect. – easyrider Apr 17 '10 at 4:54
Well thank you for solution i tried with gvfs-mount and looks like everything is working in spite of these errors: <pre> gvfs-mount -d /dev/sdb1 (gvfs-mount:17543): GLib-GIO-CRITICAL **: g_mount_get_root:assertion G_IS_MOUNT (mount)' failed (gvfs-mount:17543): GLib-GIO-CRITICAL **: g_file_get_path:assertionG_IS_FILE (file)' failed Mounted /dev/sdb1 at (null) (gvfs-mount:17543): GLib-GObject-CRITICAL **: g_object_unref:assertion G_IS_OBJECT (object)' failed (gvfs-mount:17543): GLib-GObject-CRITICAL **: g_object_unref:assertion G_IS_OBJECT (object)' failed <code> – easyrider Apr 17 '10 at 5:10

For Ubuntu 10.04, referring to methods described here:

Four methods will be discussed:

  1. The first method is manually editing Ubuntu's filesystem table. This sounds more complex than it really is.
  2. The second method, specific to Dapper, is described at MountingWindowsPartitions.
  3. The third - simple - method is to install the pysdm package (in Gutsy) and then use System-Administration-Storage Device Manager without any manual editing of the fstab file, and disregard most of the instructions that follow.
  4. The fourth and last method does not rely on modifying Ubuntu's filesystem table. Instead, it uses the automatic facilities present in Gnome. Disks are mounted just like a regular user would do (only available in Hardy and Karmic).
  1. Is more complex than is advertised. Later on it turns out that the described method includes risks.

  2. Specific to Dapper as mentioned - outdated.

  3. Pysdm does not work right now:

  4. "uses the automatic facilities present in Gnome" which was the method this thread already mentioned in the first place; not working.

So, there are four methods, but still no solution for automounting a partition in 2011.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .