Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since upgrading my hardware (mobo, CPU and memory) a couple months ago my computer no longer automatically suspends and hibernates after the configured idle periods. Both functions work just fine manually, but if I leave the computer on overnight it's still active the next morning even though it's configured to sleep after 3 hours and hibernate after 6 hours.

The system is:

Mobo       : MSI 790GX-G65
CPU        : AMD Phenom II 965 BE at 3.4 GHz
Memory     : Corsair DDR3 1600, at 1333 MHz and 9-9-9-21
HDDs       : 1 EIDE (System - O/S, Programs, etc), 2 SATA in RAID-0 (Data)
DVD        : 1 LITE-ON DVDRW SOHW-1673S
Card Reader: 1 multi-card reader
O/S        : Windows XP Pro SP3

Keyboard is attached via PS2 and mouse is USB.

How do I diagnose the cause of this?


EDIT: 2010-07-22

Since it seems most likely that this is an application or service resetting the idle counter, does anyone know how to observe and/or track this counter?


EDIT: 2010-07-28

Some testing shows that it automatically suspends up to 30 minutes, but not when set to 3 hours. Or perhaps it suspends only when Admin is logged on. Or perhaps it depends on which account is left active.

share|improve this question
add comment

5 Answers 5

Since the problem comes probably from the hardware change, I suggest you test your Windows memory. You can use "Windows Memory Diagnostic" for this purpose after reading the user guide.

The Windows Memory Diagnostic tests the Random Access Memory (RAM) on your computer for errors. The diagnostic includes a comprehensive set of memory tests. If you are experiencing problems while running Windows, you can use the diagnostic to determine whether the problems are caused by failing hardware, such as RAM or the memory system of your motherboard.

The download link and user guide can be found here.

Microsoft also has a help page for "How to troubleshoot hibernation and standby issues in Windows XP".

As another suggestion for the solution to the problem, you can take a look at "Standby & Hibernate Issues in Windows XP". There are several standby and hibernate issues discussed along with the solutions.

Finally, there is a great post about "Windows XP Standby and Hibernate Problems" by Tom Harrison. The author shares his experience with these issues and suggests some solutions. For example, he says:

Quick note for people looking to diagnose standby/hibernate issues: files open on remote computer seem to prevent standby.

I suggest you read the whole post as he states he is pretty expert in diagnosing standby and hibernate issues.

share|improve this answer
    
Memory was thoroughly and exhaustively tested as part of the hardware build and BIOS tweaking. The files on remote computers could be a lead, since I do work off a VPN, though I normally disconnect the VPN, I do routinely leave the remote drives mapped. –  Lawrence Dol Jul 14 '10 at 18:10
    
I have eliminated having networked drives mapped and having the VPN open as possible causes, by ensure that neither was true and having the system still fail to sleep on schedule. Maybe I need to figure out how to force feed the computer some Lunesta? –  Lawrence Dol Jul 22 '10 at 14:18
add comment

Sleep and Hibernate are controlled by ACPI, and it's settings will have changed when you got your new Motherboard. Have you installed the latest BIOS for your motherboard? When you go into your BIOS are there any options dealing with power saving, standby or suspend that you could fiddle around with? Suspend and Hibernate on windows are also stopped by critical file transfers or certain programs purposefully keeping the computer awake. (For Example torrent programs have an option for this to let you download while you are sleeping.) Do you have any of those programs?

My best bet is BIOS though, flash up to the latest version.

Also are you sure your mouse isn't moving a little to make your computer never go into the inactive state? Maybe some faulty or hypersensitive mouse?

share|improve this answer
    
Yes, the BIOS is latest. I am not aware of any programs that would prevent sleeping - and, as stated, manually putting the computer to sleep works consistently. No, my mouse isn't moving, nor is there any keyboard activity. –  Lawrence Dol Jul 14 '10 at 18:08
add comment

To verify the system power management settings you can use this article as a checklist:
An Introduction to Power Management and its Features.

If this doesn't ring a bell, here are some more ideas:

  1. Verify the Power scheme in "Start > Settings > Control Panel > Power Options".
  2. Look in your BIOS for the suspend ACPI options and try to switch it to S3 (suspend to system memory) or S4 (hibernate - suspend to system disk) or a combo such as S1+S3.
    More info is here.
  3. See this fix Use this registry file to enable S3 sleep mode in Windows XP. For more info see here.
share|improve this answer
    
Option (3) requires I register with TR - can you add the fix to your answer so I can check if it helps; I don't need yet another website with my email and a registration. –  Lawrence Dol Jul 18 '10 at 0:18
    
BTW: This overview is fine, such as it is, but it doesn't help if everything is configured correctly in BIOS and Windows and it still doesn't sleep on idle. –  Lawrence Dol Jul 18 '10 at 0:20
    
If (3) refers to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\usb with “USBBIOSx” = DWORD:00000000, then my computer is already set (as is probably indicated by the fact that it manually goes into S3 and S4 sleep states and wakes from them just fine). –  Lawrence Dol Jul 18 '10 at 2:01
    
@Software Monkey: I suspect that this is indeed what this file does. I suggest that you check the power settings of all devices, especially the ones that changed. See also this article for some tips : exoid.com/?page_id=47. If everything is done correctly then there is no reason for it not to work, so you must be missing up on some detail. –  harrymc Jul 18 '10 at 6:59
    
@Harry: I did go through the power settings of all devices - nothing was untoward. At this point I suspect strongly that some (stupid) application is resetting the idle counter, but I have no idea how to diagnose which one. –  Lawrence Dol Jul 22 '10 at 14:14
show 2 more comments

Might sound a bit funny, but have you tried removing all the input devices from your computer to see if it makes a difference? i.e. Try removing the keyboard, mouse and other devices just to make sure that they don't have a part to play.

share|improve this answer
add comment
up vote 0 down vote accepted

Solved this problem by upgrading to Windows 7 x64... now all power management functions work as expected on this hardware.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.