Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my friend's hard drive mounted externally. After messing with the permissions with TAKEOWN so I could fix some viruses, I have full control over their drive. The problem is, now it's stuck in a "autochk not found" reboot sequence. I think the problem is that the boot sector is invisible to the drive now.

So my question is, How can I use icacls to give back the full ownership, when the user I am giving it to is not on my machine?

I ran the TAKEOWN command from my Windows 7 laptop, their machine is Windows XP Pro with three partitions. I only altered the one that has the boot sector.

Here is the permissions that icacls shows: (Where my computer is %System% my username is ME, and the drive is E:\

C:\Users\ME> icacls E:`\`*

E:\$RECYCLE.BIN %System%\ME:(OI)(CI)(F)
                Mandatory Label\Low Mandatory Level:(OI)(CI)(IO)(NW)

E:\ALLDATAW %System%\ME:(I)(OI)(CI)(F)
E:\alrt_200.data %System%\ME:(OI)(CI)(F)
E:\AUTOEXEC.BAT %System%\ME:(OI)(CI)(F)
E:\AZ Commercial %System%\ME:(I)(OI)(CI)(F)
E:\boot.ini %System%\ME:(OI)(CI)(F)
E:\Config.Msi %System%\ME:(I)(OI)(CI)(F)
E:\CONFIG.SYS %System%\ME:(OI)(CI)(F)
E:\Documents and Settings %System%\ME:(I)(OI)(CI)(F)
E:\IO.SYS %System%\ME:(OI)(CI)(F)
E:\Mitchell1 %System%\ME:(I)(OI)(CI)(F)
E:\MSDOS.SYS %System%\ME:(OI)(CI)(F)
E:\MSOCache %System%\ME:(I)(OI)(CI)(F)
E:\NTDClient.log %System%\ME:(OI)(CI)(F)
E:\NTDETECT.COM %System%\ME:(OI)(CI)(F)
E:\ntldr %System%\ME:(OI)(CI)(F)
E:\pagefile.sys %System%\ME:(OI)(CI)(F)
E:\Program Files %System%\ME:(I)(OI)(CI)(F)
E:\RECYCLER %System%\ME:(I)(OI)(CI)(F)
E:\RHDSetup.log %System%\ME:(OI)(CI)(F)
E:\System Volume Information %System%\ME:(I)(OI)(CI)(F)
E:\WINDOWS %System%\ME:(I)(OI)(CI)(F)

Successfully processed 22 files; Failed processing 0 files

C:\Users\ME>
share|improve this question

migrated from stackoverflow.com Apr 17 '10 at 18:33

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer 1

Try adding Everyone:Full Control and System:Full Control to all files. The machine name is part of the ACE, so even if you have the same name on your machine it won't carry over. I don't have a Windows 7 computer here to test it on, but on XP using cacls it'd be something like:

cacls e:\* /t /g everyone:f system:f
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.