Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The wireless internet on my Mac became extremely slow recently on my 27" IMac. I don't recall doing anything different other than doing the Apple Software updates which I let it pop up and install automatically. On my Mac Book internet is still fine so I don't think it's the model or the router.

I'm not sure where to start digging the cause of this or how to solve it. Looking into the System Preferences on my IMac, it's pretty identical to my MacBook!

share|improve this question
    
what version of OSX are you running? –  quack quixote Apr 17 '10 at 20:10
    
I'd also ask you to check the physical position of your IMac, there isn't anything metallic or something electrical, or some form of transmitter between it and the Wireless access point is there? These things are finnicky, whilst a really obvious issue it's worth considering either way. –  Dmatig Apr 17 '10 at 20:28
    
@Quack Quixote its Snow Leopard. @Dmatig I don't think so because it used to work before and I have changed my room layout plus I put my MacBook beside it and it works fine. Thanks –  Tam Apr 17 '10 at 21:48

1 Answer 1

up vote 1 down vote accepted

I am having the same issues on mine, but it appears to be related to the heat of the machine. If I leave it off for a long period of time and boot it up, the wireless link functions as it should. After it's been on for a long time, it begins to slow way down and eventually drop the connection. Can you trace your problem to the amount of time it's been running?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.