Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Last year I built a Core i7 920 system based on the ASUS P6T Deluxe motherboard. I have 3x1GB of DDR3 (triple-channel configuration), but only 2GB is being reported by: Windows XP, CPU-Z, the BIOS. Is this a hardware problem, or is the third gigabyte of RAM being reserved by the system for video card-related stuff? The video card has 512MB of RAM.

I realize that 32-bit Windows XP is not the ideal operating system for more than 2GB of RAM, but from what I've read it should be reporting at least 2.5GB.

share|improve this question

migrated from serverfault.com Jul 26 '09 at 16:10

This question came from our site for professional system and network administrators.

add comment

5 Answers

up vote 8 down vote accepted

If the BIOS is reporting 2Gb, then it's a hardware or BIOS problem, nothing to do with XP.

First thing I'd do is try the RAM two sticks at a time to see whether they're all good. Second thing would be checking if a BIOS upgrade is available.

share|improve this answer
4  
1/ press the sticks down firmly, to make sure they are properly installed. 2/ get 1 stick at a time to show up, by removing them all, and trying one by one. It's usually the simplest things, hence 1. –  Alister Bulman May 3 '09 at 19:22
    
You can also try a memtest to check if everything is okay –  setatakahashi May 7 '09 at 12:04
    
This answer was the closest to being correct, so points to you. I ran CPU-Z and it reported that Slot C1 was empty, so I opened the case, reseated the stick, and it's now coming up as 2.99 GB in WinXP and 3 GB in the BIOS. –  Scott May 29 '09 at 3:06
add comment

I have used a XP Machine (32 bit) with 4 GB so i know that it supoprts upto 4 GB. since you are saying that BIOS is also reporting it as 2 GB , this should be a hardware problem, you probably need to test the slots or do some switching of the RAM modules to identify the faulty one.

share|improve this answer
add comment

Double check what the BIOS is reporting. I suspect that your memory is actually there, but remapped over the 4GB limit: a 32bit OS will be able to see only 2GB, the BIOS should report the correct amount of memory though.

Your memory map might something like:

0-2GB physical memory
2-4GB hole for MMIO
4-5GB physical memory

My P5B-E does the exact same thing, but I'm running a 64bit OS...

share|improve this answer
add comment

Try enabling the /3GB switch in your boot.ini.

http://support.microsoft.com/kb/833721

share|improve this answer
3  
The /3GB switch is for Virtual Address Space for applications,not Physical Memory. If the Bios is not recognizing the memory, there is no point looking for it at OS level –  Dinesh Manne May 3 '09 at 18:40
add comment

In the bios, there should be a setting for dual or triple channel memory.

share|improve this answer
    
Sounds like he's probably using it, from his question. –  chaos May 3 '09 at 18:50
2  
With these boards, you can put in the 3 sticks of ram, leave it defaulting to dual channel and it will boot fine, just picking up 2 of the 3 sticks. –  Ryaner May 4 '09 at 8:30
    
There is no BIOS setting; it's automatic. –  Scott May 29 '09 at 3:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.