Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 64bit on a laptop (Samsung R560) using a cheap external CRT monitor.

The screen is a littler dark for my liking, despite having the physical monitors settings up to the max for all the brightness-related settings.

Windows 7 has a tool called "Calibrate display color" (search in the start menu). Running this tool, you have a slider that allows you to adjust the "Gamma", which sliding up gives me acceptable brightness levels.

Unfortunately, upon reboot (and certain other activities such as running certain fullscreen games) this is reset to default.

Is there a way to make this persistent? Some registry setting? Batch file to run at startup even (less preferable as I'd like games to run brighter too)?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

According to what I see from this laptop's specifications, the graphics card is an NVIDIA GeForce 9600M GS.

NVIDIA drivers contain a control panel (which should be accessible in the system control panel, from the contextual menu on the desktop, or from a tray icon), in which you can set different parameters, like which 3D effects to use, performance on battery, multiple display, etc.

Between these settings, you can also find something like "Adjust Color settings", in which you can set the brightness, gamma, etc. It's possible that these settings have a priority over the ones from the OS, so try to change there, maybe it will keep them.

nvidia control panel

It should be as well the base for 3D applications such as games, but keep in mind that each of them can set their own, so most likely you would have to deal with each of them individually.

share|improve this answer
add comment

To stop the display resetting to original settings on startup, thus saving your desired gamma, do the following:-

start > run > msconfig > startup > uncheck igfxpers.exe

I just found this out today, after weeks of calibrating every time I start up my laptop! :)

share|improve this answer
    
This was the solution for me on my Dell Vostro 1015 laptop, which uses Intel's integrated graphics card. Thank you my friend, I've been struggling with this for months! If I could I'd give you all the reputation points available here at SU on the spot for this fine answer! –  Kohányi Róbert Jan 18 '12 at 8:43
add comment

the proposed solutions are only applicable to certain gfx cards and are rather workarounds. There seems to be a more general problem:

see http://social.answers.microsoft.com/Forums/en-US/vistahardware/thread/138fb2a2-c854-42f1-aa2a-2c4cdc549930 for possible solutions

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.