Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried upgrading the version of LibXML2 in my machine to run some propietary software. Compiled as 32-bit (-arch i386) and restarted to see if it worked. Now when I try to boot I can only get into the spinning screen and it just sits there.

Restarting in verbose mode (Cmd-V) does not show any error in the process, it just freezes after "AppleIntelCPUPowerManagement: initialization complete". I can't from any CD either (if I press c on startup it just spins the disk around and then stops in the same spinner screen).

I've also reset the PRAM/NVRAM to discard any problems with that and it´s still not fixed.

Any pointers of what might´ve gone wrong?

(Latest gen MBP, running 10.6.3)

share|improve this question
add comment

1 Answer

libxml is pretty much fundamental to OS X since plists are used all over the place, even for launchd and kernel extensions which are loaded right at system start up.

In my standard installation of Snow Leopard 10.6.3, libxml.2.2.dylib has been compiled for 3 architectures:

$ file /usr/lib/libxml.2.2.dylib
libxml2.2.dylib: Mach-O universal binary with 3 architectures
libxml2.2.dylib (for architecture x86_64):  Mach-O 64-bit dynamically linked shared library x86_64
libxml2.2.dylib (for architecture i386):    Mach-O dynamically linked shared library i386
libxml2.2.dylib (for architecture ppc7400): Mach-O dynamically linked shared library ppc

My guess is you've only compiled it for i386 but something requires the 64-bit version?

I don't understand why booting from a CD won't work though since it doesn't go near any system files on your hard disk. Booting from CD does take a while, did you leave it long enough?

share|improve this answer
1  
This is why MacPorts and Fink smartly install their own versions of things under /opt and /sw respectively. This is a lesson Homebrew is learning as well. –  Spiff Apr 19 '10 at 6:07
    
I think the CD boot is not related directly to this, I've alway had issues with that. I'll try to restore the file today via FireWire or something and update the question. –  Federico Apr 19 '10 at 17:02
    
Also various apple functions might rely on the exact version of libxml that apple installs - if you need a later version install elsewhere –  Mark Apr 26 '10 at 18:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.