Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Somehow I keep hitting a shortcut key (or something similar) that enables the input of accented text. Whenever this accented text mode is enabled, pressing ' doesn't respond immediately; instead, the ' key is remembered, so if I press a vowel after that, I get the vowel with an acute accent mark, and if I press any other key, I immediately get an apostrophe followed by the other key.

I don't want this to happen. It's very annoying. How do I disable this mode?

I've seen this behavior in Firefox, Pidgin, and Outlook. It apparently happens on a per-application basis, and restarting the application fixes it. I checked Windows 7's "Region and Language" control panel and didn't see anything relevant (although I'm not intimately familiar with all of those settings, so I may have overlooked something).

Edit: This is apparently not the same thing as changing keyboard layouts. I removed all non-U.S. keyboards from my keyboard control panel and am still seeing this behavior, and pressing LAlt+Shift (which the keyboard control panel lists as my "between input languages" shortcut) does nothing.

share|improve this question

4 Answers 4

What you're seeing is the keyboard switching to "U.S. International". Check the Keyboard control panel and make changes as appropriate.

share|improve this answer

The shortcut key for switching keyboards is by default LAlt + Shift.

If you have multiple keyboards set up (for example US and United States-International), this will toggle between the two. The first has the "normal", desired behavior. The second is the keyboard with the "sticky apostrophe".

As a Dutch and English writer, I find it useful to be able to toggle between the two using the keyboard shortcut. Bear in mind, however, that Windows remembers the setting per application. If you wish to use multiple languages, I recommend setting up two languages with different keyboards, and displaying the Language Bar's active language in the system tray:

Language settings in Windows 7

share|improve this answer
up vote 3 down vote accepted

I finally solved this:

I had turned on EnableHexNumpad (as described on fileformat.info) for easier entry of Unicode characters. Apparently having EnableHexNumpad on means that LAlt apparently acts as AltGr and pressing RShift + RCtrl can enter the "sticky apostrophe" mode.

Turning off EnableHexNumpad makes my keyboard act like a regular U.S. keyboard again.

share|improve this answer

Actually, it's important to clarify that Alt + Shift switches between different languages, e.g. English and Dutch, and Ctrl + Shift switches between different keyboards in a language, e.g. toggling between the US and US-International Keyboard. On my computer, it responds to either the left or right Ctrl, Alt, and Shift .

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.