Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I disable the Gnome window manger keyboard control for control-alt-arrow (left, right, up, and down arrows) to scroll between workspaces?

This is a key binding I use in Emacs and the window manager is snarfing it before it gets to Emacs.

share|improve this question
add comment

4 Answers 4

I'm running Ubuntu and all the keyboard shortcuts gnome uses are under System, Preferences, Keyboard shortcuts. I'm fairly sure it would be the same for all distributions that use gnome.

If you scroll down to the bottom of the Window Management section, you can disable or change the key combination that performs that action.

You can also find many other useful key bindings there.

share|improve this answer
add comment

If you are running Compiz you need to open up the preferences for the window manager. The key bindings are all against the effects. I'm not running Compiz so I can't look any further for you, hope it helps.

share|improve this answer
add comment
up vote 0 down vote accepted

For RedHat it is under menu item Applications -> Preferences -> Keyboard Shortcuts is the dialog where these key bindings are kept. Select the row to disable and hit the backspace key to remove a shortcut.

share|improve this answer
add comment

I wanted to free up the same keys for use in Eclipse, on Red Hat Enterprise Linux 6.x (Gnome 2), but I couldn't find any Workspace Switcher shortcuts in Applications -> Preferences -> Keyboard Shortcuts.

I was able to delete the unwanted shortcuts by running gconf-editor and visiting the node /apps/metacity/global_keybindings/switch_to_workspace_down (and nearby keys) and setting the value as disabled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.