Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I get a black screen when I boot my laptop.

The laptop was in sleep mode initially, so when I pressed the power button, it looked as if it woke up from sleep mode, but the screen was blank. So, I held down the power button to force shutdown the laptop and then removed the battery. But after booting the laptop the screen still remains black. The bios/boot screen remains black as well.

I have tried connecting it to external hdmi/vga/s-video devices and booting still no go.

Windows loads fine, as I can type the password and get the 'Ding', then alt-f4 and shutdown windows.

If it helps, the laptop model is Asus G1S-A1.

Thanks in advance!


After several hours of searching for a solution, I have decided to give up on this. The best option is to replace the motherboard, since the GPU is soldered on the MB. I would have happily replaced the MB, but couldn't find a replacement anywhere online.

So, I will have to buy a new laptop (!asus) pretty soon and transfer the data+code.

Thanks for your response.


I got it to work!!! Opened the laptop and used a hot air gun @200F and heated the GPU for about 1 minute. Then used a cloth to pressed the chip and held it for sometime. Applied back thermal paste, put back heat sink etc. and voilà! I think, I just got lucky.

Disclaimer: I disclaim any liability for any damages that may result from performing above steps.

share|improve this question
when you say no go with an external screen attached, do you mean you get no picture on the external monitor, or that the built-in one is still black but with a picture on the external? – eidylon Apr 20 '10 at 3:17
@eidylon I'm pretty sure he means no video output anywhere, which makes this .. tough – Jeff Atwood Apr 20 '10 at 5:27
Running into this exact same issue...not excited about this solution, hah. But I'm glad to know it was fixed. Machine is running on five years old or something at this point, so I guess it might be time to put it to pasture. – bwerks May 19 '12 at 18:24

That is a tough one -- if it was a desktop machine I would recommend

  1. resetting the BIOS
  2. trying a different video card (if available)

But as a laptop your troubleshooting options are .. more limited. You've tried booting with external video devices which is about all I can think of!

You may want to give ASUS support a call on this one; hopefully it is under warranty?

share|improve this answer
Unfortunately it's already passed the warranty date! – Vivek Apr 20 '10 at 0:28
Hmmm... time for, maybe. – Nathaniel Apr 20 '10 at 4:05

What happens if you boot off a live CD? Like a live Linux CD? Or a USB memory stick? This may be nearly impossible if your BIOS is configured to boot from CD after booting from the hard drive... But it's just a thought.

share|improve this answer

I had the same problem with a different ASUS model (Aspire Timeline 4810TG). Turned out my wife had unknowingly switched it to use the external graphics port, and for whatever reason it could not be switched back without connecting an actual external display. Even reboots did not work. So, try hooking up an external display, and then switch the display configuration with the "Fn" key a couple of times before you send in the machine for repair.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .