Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have gone through two external hard drive enclosures and have had this issue with both, though not one from five years ago. When I turn off my Windows Vista Ultimate x64 system, the external hard drive enclosure (USB 2.0) powers down the hard drive, though stays on. When I turn my computer back on, the external hard drive remains off. The only way to get the drive to spin up again is to turn it off and wait for a few minutes before turning it back on.

This enclosure exhibits the same behavior regardless of what USB port it is hooked to. I have three USB ports on the chassis of my laptop and four more on a docking station.

This enclosure has always exhibited this behavior since I purchased it. The previous enclosure that I had seemed to have heat issues that caused it to spin down randomly and required you to put it in the refrigerator for a while to cool it down enough for it to spin up again. I'm not sure if this enclosure is exhibiting the same behavior or if this is unrelated.

Does anyone know what might be causing this problem?

Note: This is an enclosure for a 3.5in HDD that has a separate 120VAC power brick, so the computer itself is not powering the drive in any way (that I'm aware of).

share|improve this question
    
It is correct behavior to power off the hard drive when computer is shut down, even for USB devices. It seems to be a Windows bug that it doesn't instruct the device to power itself back on when the USB Mass Storage driver is loaded again on next reboot. Just a speculation though. –  Juliano Jul 26 '09 at 20:12
    
It is my experience that the external (USB) hard drive stays on when the computer is turned off, unless you manually turn off the power to it. –  Chris Lieb Jul 26 '09 at 21:18
add comment

2 Answers

Have you tried it with other machines and other operating systems? If you did and the same problem persists, you have a faulty product.

share|improve this answer
    
I would, except I don't have any other computer to test it on at home and USB mass storage devices are disabled at work. –  Chris Lieb Jul 27 '09 at 0:27
    
You can try your hard drive with Ubuntu live cds on your own computer. If it works, that would mean the Windows Vista was the cause of your problem, if not, either your hard drive or your computer has a problem. –  swamplord Jul 27 '09 at 22:09
add comment

Check your drivers of course. If that doesn't help, adjust your Control Panel -> Power options.

share|improve this answer
    
I don't see why this should need special drivers. And it works fine otherwise. I also took a look in the power options, but nothing looked promising. –  Chris Lieb Jul 27 '09 at 0:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.