Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

(Warning, clueless-newbism ahead.)

Background info: I'm actually trying to install/upgrade xdebug.

sudo pecl install xdebug yields:

downloading xdebug-2.0.5.tgz ...
Starting to download xdebug-2.0.5.tgz (289,234 bytes)
............................................................done: 289,234 bytes
67 source files, building
running: phpize
sh: phpize: not found
ERROR: `phpize' failed

A quick google tells me that phpize is a part of a package called php5-dev, so off I ran to install that.

My problem is that using sudo apt-get install php5-dev fails with this output:

sudo apt-get install php5-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-dev: Conflicts: libtool (>= 2.2) but 2.2.6a-4 is to be installed
E: Broken packages

2.2.6a-4 is greater than 2.2, so I'm not sure why it's hanging itself up at that point. I'm guessing the fact that it's not entirely numeric is throwing apt-get off?

I can probably install xdebug manually (though I've never done this before, so picture me with a deer clueless-newb in headlights look here, violently shaking my head and begging for a simpler solution) rather than via pecl / aptitude, but is there a way I can make aptitude install php5-dev despite the bogus 'broken package' claim? Is it even bogus, or am I misreading the error message?

Alternatively: Could I install phpize in some other way (e.g. via pear or pecl)?

share|improve this question

Run the following:

$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install php5-dev
share|improve this answer
I still get the same error, unfortunately. Though I've managed to find an alternate way of installing xdebug by now that doesn't require phpize (mind, this was about a month ago, I'm not sure I could reconstruct). Still, thanks for your answer. – pinkgothic Jun 17 '10 at 10:27

Try use:

aptitude install php5-dev

it will tell you that the solution to your problem is to downgrade libtool to version 1.5.26-4+lenny1 and if you accept the solution it will install the older libtool version and php5-dev installation will be successful after that without any conflicts.

share|improve this answer

Another solution:

cd /tmp
sudo apt-get remove libtool
sudo dpkg -i libtool_1.5.26-1ubuntu1_i386.deb
sudo apt-get install php5-dev

If you're running 64-bit you have to change i386 to amd64.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .