(Warning, clueless-newbism ahead.)
Background info: I'm actually trying to install/upgrade xdebug.
sudo pecl install xdebug yields:
downloading xdebug-2.0.5.tgz ... Starting to download xdebug-2.0.5.tgz (289,234 bytes) ............................................................done: 289,234 bytes 67 source files, building running: phpize sh: phpize: not found ERROR: `phpize' failed
A quick google tells me that
phpize is a part of a package called
php5-dev, so off I ran to install that.
My problem is that using
sudo apt-get install php5-dev fails with this output:
sudo apt-get install php5-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: php5-dev: Conflicts: libtool (>= 2.2) but 2.2.6a-4 is to be installed E: Broken packages
2.2.6a-4 is greater than
2.2, so I'm not sure why it's hanging itself up at that point. I'm guessing the fact that it's not entirely numeric is throwing apt-get off?
I can probably install xdebug manually (though I've never done this before, so picture me with a
deer clueless-newb in headlights look here, violently shaking my head and begging for a simpler solution) rather than via
aptitude, but is there a way I can make
aptitude install php5-dev despite the bogus 'broken package' claim? Is it even bogus, or am I misreading the error message?
Alternatively: Could I install
phpize in some other way (e.g. via