Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Win XP SP3 on an IBM R50e laptop, and I just realized a folder named c8c6ac6192a47b59df in the root of my C:\ drive. I can see 2 folders in it named amd64 and i386. These two folders cannot be opened. XP says:
c8c6ac6192a47b59df cannot be accessed. Access Denied.

alt text

However, when I view the properties of the strangely-named folder, it shows 2 folders, 0 files, 0 bytes. I tried Unlocker to be able to unlock and delete the folder, but Unlocker says there are no handlers.

What's this folder and how can I delete it?

EDIT: Thanks to ChrisF, I managed to take ownership of the folders and now able to view the contents. Both folders include same files with different sizes. Should I just delete them?

alt text

share|improve this question
See the answers to my question here -… - for how to regain ownership of this (or indeed any) folder. – ChrisF Apr 20 '10 at 13:03
Or… – Vervious Apr 20 '10 at 19:33
up vote 7 down vote accepted

While I can't say for sure, it sounds like some application installer was using the root of the drive for a temporary location, instead of the more logical C:\tmp (or some similar name). This installer forgot to wipe its temporary files or was interrupted mid-install. Deleting the files should be fine (and under Linux it would be done automatically on reboot, I might add); I would try logging in as an administrator to get around the permissions problem.

Answer to edit: Try moving the folder to a different location (bonus points for moving to a removable drive and unplugging it), rebooting, and testing various things. If all goes well, deleting it can't harm anything. Otherwise, move the folder back to its original location.

share|improve this answer
+1 Usually sloppy Windows updates – Dave M Apr 20 '10 at 13:04
My Red Hat/CentOs box doesn't empty /tmp on reboot, it waits until the files there haven't been accessed for 10 days. But then they are automatically deleted. – Kevin M Apr 20 '10 at 15:08

Based on the folder contents... I'd say it's from a Microsoft Update.

Many Microsoft updates are extracted to a temporary folder on the root of a drive (usually C, but if you have more than one drive it could be another one). These temp folders are usually removed after an update is successfully applied (after a subsequent reboot).

As suggested above, you could move or rename the folder to make sure there aren't any ill effects (there shouldn't be).

There is a post on the MS discussion board about a .Net update that left a temp folder such as the one you have.

Taking ownership of files/folders on Vista/Win7 is a piece of cake with this registry script which adds "Take Ownership" to the right-click menu. See here:

Microsoft has detailed instructions for taking ownership of files/folders in Windows XP here:

share|improve this answer

I believe those are reminiscent of Service Pack installations are are supposed to be automatically deleted. If they weren't automatically deleted (as probably in your case) they can be safely deleted. Have you installed a Service Pack recently?

To delete these folders, first take ownership of the folder and then you can just delete it. To take ownership in XP Home, start in safe mode and log in as admin to get access to the security tab... and then right click folder->properties->security tab->advanced->owner tab, then select your user, "replace owner on subcontainers and objects", etc and then you can delete. You might have tried this already... in that case I wouldn't know much else to help you :)

share|improve this answer

They are folders that updates extract to. Try deleting them once rebooted

share|improve this answer
Rebooting does not avail. – Mehper C. Palavuzlar Apr 20 '10 at 13:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.