Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Very strange behavior. Some background:

I bought a new lenovo G550 laptop, running Windows 7. I live in Israel.

When I type certain keys, in any application, they are prefaced with the backquote (`).

These characters are: Insert, Delete, Left Ctrl (the right-hand one is fine), - (the regular dash: the one on the keypad is fine), =, 5 (the regular one), 4 (the one on the numeric keypad, whether or not Num Lock is on), and PgDn (the regular one).

When I press the Fn key with these I don't get the behavior.

Does anyone know why this is happening, or how I can fix it?

EDIT: Some friends suggested that there's some faulty wiring in the keyboard somewhere. If I can get hold of an external keyboard, I'll be able to test it better. In any case, I'll call technical support.

EDIT 2: When I switch the keyboard language to Hebrew, the ` comes out as a ;. The backquote key on Hebrew keyboards is the semicolon, so this looks like a hardware problem. (I don't have sticky keys turned on.)

share|improve this question
add comment

3 Answers

So, after sending the computer to the fixit shop, it turns out there's a problem with the keyboard and a problem with the motherboard. Good thing I sent it in!

share|improve this answer
add comment

Just a thought, but you might have "stickyKeys" enabled on your keyboard (pressing shift 5 times in a row)

share|improve this answer
add comment

It's possible your system is using a different keyboard language than that of your keyboard is set up.

I use a Windows server as my main computer thats located in a different country, and my friends have logins so they can remote into it, and they're from the UK.

I can always tell when they log on because my @ suddenly becomes a " and vise versa.

Try setting your keyboard language.

EDIT: Set it to American English, and tell me what the shift+2 spits out, as well as the `. Might not help, but couldn't hurt.

share|improve this answer
    
The keyboard basically works. It's just that some characters are prefaced with a `. ` comes out as `. Shift + 2 comes out as @. BUT 5 comes out as `5, or sometimes 56. = always comes out as `=. I'm sending it in to be tested under warranty, and I guess they'll remove the beetles or whatever. –  JXG Apr 25 '10 at 7:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.