Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a hard drive I need to backup. In the hard drive is of course things like Documents and Settings which is set to not allow other people to see inside someone's personal folders.

I am an administrator though, and I can not figure out how to mark these files so that I am permitted to access them and copy them. When I double click on My Documents then it pops up saying You must have permission to access this and gives me an option like OK or Cancel. I click OK and then it says you do not have permission to access these files.

I'm an administrator on the system, so I don't understand why Windows Vista is locking me out.

How can I setup Windows Vista so that it will let me copy every file, even ones I don't have permission to?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

I ended up just putting the hard drive in an Arch Linux box, and mounted it with NTFS-3G, and it copied almost everything. Apparently the hard drive was half-bad or the file system was slightly corrupted though, because there were some "No such file or directory" error and "Input/output errors" messages, but that was only like four files.

So I guess that tutorial I tried to do was right. As step 15 it said

Ask yourself why you're still using Windows.

share|improve this answer
add comment

It is possible that User Account Control is stopping you. But most likely you just need to take ownership of their files. See the link below:

http://www.vistax64.com/tutorials/67717-take-ownership-file.html

share|improve this answer
    
I have disabled UAC and also I would like to keep from modifying the harddrive to be copied very much because I am only doing this for backup as a "just in case" so that I can fix malware issues. So the computer must still run afterwards as if nothing has happened –  Earlz Apr 20 '10 at 22:07
    
I do not currently have a Windows 7 machine here that is not in a domain, so I cannot get into the User control panel to test this... BUT, in Windows XP there is a checkbox when creating a user to make their profile and files private. I would suggest going into the user control panel, selecting each user and looking for this option and disabling it. That setting is what locked down a users folder in XP. –  James Watt Apr 21 '10 at 13:03
    
Also, please realize that after a use has logged into a computer, you will be unable to copy many of the system/hidden files in their profile folder. These files will remain locked/in use until after the computer has been rebooted. The work around to this is having an administrator / non-user account that is used for only backups. Log in as this user after a reboot to copy everyone's home directories. In reality what you need to do is invest in software that can utilizes Windows Shadow Copy, which can copy all files regardless if they are in use or not. –  James Watt Apr 21 '10 at 13:05
    
ok figured out that the problem is actually a virus which apparently went crazy on the permissions, so all of this may be irrelevant.. –  Earlz Apr 21 '10 at 19:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.