Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using FireFox 3.6.3.

I noticed in the last couple of days that several webpages which I visit regularly are not rendering properly. A lot of the text is overlapping with other text and it basically looks like the style sheet is completely screwed up.

I have tried disabling all of my Add-Ons and it doesn't make a difference. When I use Coral IE Tab to render the pages using IE they display without any problems.

The websites which are not rending properly for me are:

One interesting thing I noticed is that if I modify the Google Reader URL to not use SSL (i.e. change https to http) it renders without any issues. However, The Age website is not using SSL, and that still doesn't render properly.

I have also disabled my Proxy Server (I normally use one at work) but this doesn't make a difference either.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Try crtl + shift + r to force a complete refresh. Then install firebug and see if you are even getting the CSS files for those pages. Click the network tab and you will see if the css files are 404'ing or 200'ing (200 being Document Received/OK).

share|improve this answer
    
It turned out to be a combination of my proxy sending me a cached copy of the CSS, and an adblock rule blocking the CSS. Disabling and re-enabling AdBlock, and forcing a refresh seemed to solve the problem. Thanks! –  LeopardSkinPillBoxHat Apr 23 '10 at 4:19

I had a similar problem where all of a sudden all of the web pages I went to stop rendering properly in my firefox browser and I had no idea what was going on. So although I loved firefox I stopped using it because of that. I found this site through google and the solution given did not work exactly for me, it gave me some ideas and I found the fix. I used the firebug toolbar and clicked on the disable drop down arrow and looked and what was checked and I unknowingly had my page colors disabled! A very simple solution that I could not see! I initially did no have firebug installed when I started using Firefox and I never bothered to use it before! Thanks for this site!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.