Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Background
I regularly use Windows Explorer to browse my drives and data, and I notice little freezes and hiccups at times. It's especially noticable when browsing local or network folders with lots of video files (AVI, MKV, MPG, etc).

I almost always browse in Details view, and the "Do not cache thumbnails" option is turned on. Even though I'm in Details mode, I'm convinced the sluggishness is due to Windows trying to generate thumbnails for the video files, so I want to disable thumbnail generation for these files.

I occasionally use Thumbnails view for browsing image files, so I don't want to disable all thumbnails. But for future reference, this might be good to know.

Questions

  • How do I disable thumbnail generation for all non-image files?
  • How do I disable thumbnail generation for all files?
  • How do I disable thumbnail generation for one specific filetype?

Finally, how do I undo (re-enable thumbnails) once I've performed one of the above?

share|improve this question
    
if necessary, assume that i'm familiar with regedit for purposes of the one specific filetype part. –  quack quixote Apr 21 '10 at 2:01
    
Bad question quack. How are you going to select one answer if you get your three questions answered by three different persons? I added my 2c to Hugh's answer below –  Nifle Apr 21 '10 at 10:00
4  
@nifle: hey man, i know the mods around here... if i post them as three separate questions they'll close two as duplicates and yell at me for posting three highly-related questions. –  quack quixote Apr 21 '10 at 10:11
    
Dang quack, you almost made me choke on my coffee with that one –  Nifle Apr 21 '10 at 10:36
add comment

3 Answers

up vote 14 down vote accepted
+550

1. Disabling thumbnails for all video types

  • Disable: regsvr32 /u shmedia.dll
  • Enable: regsvr32 shmedia.dll

(source 1, source 2)

2. Disabling thumbnails for all image types

  • Disable: regsvr32.exe /u shimgvw.dll
  • Enable: regsvr32.exe shimgvw.dll

Alternately, you can disable them in RegEdit by clearing (ie, setting the value to blank, empty space) the "(Default)" value on the following key:

HKEY_CLASSES_ROOT\SystemFileAssociations\image\ShellEx\ContextMenuHandlers\ShellImagePreview

For easy restoration, backup (export) the key first, then merge your backup into the registry; or set the value back to its default of "{e84fda7c-1d6a-45f6-b725-cb260c236066}".

(source)

3a. Disabling thumbnails for individual video types

The K-Lite Codec Tweak Tool will conveniently accomplish this. It works by backing up and deleting the following registry key (where .xxx is a file extension):

HKEY_CLASSES_ROOT\.xxx\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}

Manually removing this key with RegEdit also works; again, export the key first to be able to restore it.

3b. Disabling thumbnails for individual image types

I've tried (in a virtual machine!) deleting all registry keys featuring the string "jpg", to no avail. I don't think it's feasible, short of hex-editing some system DLL.

share|improve this answer
    
one outta 3. it's a start. :) –  quack quixote Apr 21 '10 at 3:45
    
Added info for video files –  Nifle Apr 21 '10 at 10:04
    
two! two out of 3! ah-hah-hah-hah-hah! –  quack quixote Apr 21 '10 at 10:09
    
@Quack - wondering, have these 2 points sped up your computer? –  Moshe Apr 23 '10 at 20:57
    
@moshe: the second one here turns off non-image thumbnails, and yes, i do notice a difference browsing my media folders. i have not tried the first one (image thumbnails) but my research indicates it's the correct way to disable those. –  quack quixote Apr 23 '10 at 21:12
show 3 more comments

This should help you:

  1. Open Control Panel. (Classic View)
  2. Click on the System icon.
  3. Click on the advanced system settings link.
  4. Under Performance, click on the Settings button.
  5. In the Visual Effects tab, uncheck "Show thumbnails instead of icons."

As for disabling thumbnails for a particular image type, you will need to disable the thumbnail preview engine listed in the registry. This is not easy, I would just leave it as "on" or "off".

share|improve this answer
    
Show thumbnails instead of icons isn't an option on that panel on my system (WinXP SP3). are these directions for Vista/7 systems? in any case, this question isn't about performance; it's about thumbnails. forget easy, i'm looking for details. –  quack quixote Apr 21 '10 at 4:10
    
I checked my XP system and the option is not there. In terms of "details", check my answer here with some registry keys and the COM interfaces for you to investigate. –  ta.speot.is Apr 21 '10 at 4:35
    
yeah, i saw that answer earlier, it's what got me thinking about this again. doesn't actually explain anything tho. :) –  quack quixote Apr 21 '10 at 4:42
add comment

The Do not cache thumbnails option stops Windows from generating a thumbnail cache (a hidden file in each folder containing the thumbnails - named thumbs.db). This forces Windows to generate the thumbnails each time it needs them. If you are willing to put up with the hidden file then unchecking the option will let Windows use the cached values which should speed things up.

share|improve this answer
    
that's a decent workaround for getting rid of the symptom i complain about, but it doesn't answer the questions asked. i usually post helpful-but-not-direct-answers like this as comments instead of answers. –  quack quixote Apr 21 '10 at 2:44
4  
Point taken, but I was trying to answer your fundamental question of how to avoid the hiccups. –  Wayne Johnston Apr 21 '10 at 3:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.