Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to enable the "extra" visual effects on Ubuntu. When I choose the option for "extra," it searches for drivers and then says, "Desktop effects could not be enabled." Why doesn't this work on my computer?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

The problem might be that restricted drivers necessary for your graphics card are not enabled.

Go to System -> Administration -> Hardware Drivers and see if there are any restricted drivers available for your graphics card. If so, enable them, reboot, and you should be able to use desktop effects.

share|improve this answer
add comment

I got the same message when I was running an Ubuntu virtual machine inside Virtualbox. I got it to work by enabling 2D and 3D hardware support within Virtualbox. That may be the same thing that's accomplished by switching drivers when you're running Ubuntu, straight, not inside a VM. Or maybe there's a setting for 2D and/or 3D acceleration that you need to set inside xorg.conf or via a graphic dialog before desktop effects will work. Just a guess. . . .

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.