Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I decided recently I wanted to give Linux a go so I first download a Ubuntu boot CD.

The boot menu came up fine, and then a glowing Ubuntu logo was in the middle of the screen for a while. Then the screen was flickering orange and black. I guess this is where the GUI should've came up. Pushing Ctrl+Alt+F1 brought me to the command prompt OK.

I thought this may have something to do with Ubuntu, so I downloaded Linux Mint. The same sort of thing happened. It booted fine, displayed it's logo for a while and then flickered, only green and black this time.

Does this sound like a video card problem?

How can I resolve this?

Many thanks

Update

I just tested the Linux Mint CD on another computer (a Toshiba laptop), and it worked perfectly.

share|improve this question
    
What Graphicscard and what PC do you have? –  Bobby Apr 21 '10 at 13:51
    
@Bobby I have a Nvidia geForce 7600 GS and PC is just a 1.86 dual core with 3gb ram –  alex Apr 21 '10 at 13:53
    
This could be a problem with the GF/Resolution (as DevSolar) pointed out. I had a similar problem on a PC with 5600, the desktop wouldn't boot up and I had to install the nvidia-drivers first to make it work. Though, I'm not sure how this would help with a Live-CD session. –  Bobby Apr 21 '10 at 13:58

2 Answers 2

I had a problem with Ubuntu / Mint which, I assume, has a similar reason: The boot screen runs at a lower resolution. When the GUI comes up, the system tries to guess the type / resoultion of your screen. In my case - an older laptop model - it was unable to determine the screen type ("Unknown") and defaults to 1600x1200.

I don't know what possessed the maintainers to go for such a default...

In my case, the desktop came up, but I was only able to see the top-left corner. I got around the problem by calling the command window (Alt-F2), typing gnome-display-properties, dragging the window into the viewable area, and setting a proper resolution for my system (1024x768).

In your case (completely unusable GUI), the above solution won't work for you obviously, so you'll have to edit the config files manually to get a rudimentary GUI running (from which you could make further adjustments). I am not sure where Gnome keeps those configuration settings (/etc/X11/xorg.conf or elsewhere), and cannot access my Mint box right now to check it out, so I cannot give you further directions, sorry.

But it might give you a start to work (Google...) from.

Any Gnome groks around who can pick up from here?

share|improve this answer
    
Thanks for the starting point, I'm a complete Linux noob so not sure where I should start with editing config files. –  alex Apr 21 '10 at 13:54
    
In that case, you should either try some other distro that doesn't exhibit this problem, or prepare for a deep plunge - X11 configuration is en par with configuring your own kernel, i.e. the most difficult thing to get right on a Linux system. ;-) –  DevSolar Apr 21 '10 at 16:31

Doing this as a second answer, so you'll get notified next time you visit SU.com. I've finally been able to try some things on my Mint box...

On the command line, edit ~/.config/monitors.xml to suit your display, then restart. This has the same effect as setting the values in gnome-display-properties.

Edit: My file as an example, just in case yours doesn't carry any meaningful values to start with.

<monitors version="1">
  <configuration>
      <clone>no</clone>
      <output name="VGA-0">
      </output>
      <output name="DVI-0">
      </output>
      <output name="LVDS">
          <vendor>QDS</vendor>
          <product>0x0040</product>
          <serial>0x00000000</serial>
          <width>1280</width>
          <height>800</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
      </output>
  </configuration>
</monitors>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.