Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I take a class in the building of a business and we sometimes use their internet via Wi-Fi. In the last few weeks, though, some of our notebooks haven't been able to connect to the internet even though they are connected to the router. It affected first a few of us and then all of us.

Last week I tweaked around the network settings on the router (yes, the admin password is the same as the network key) and even moved the internet cable on the router from port 1 to the internet port. None of this really worked so I put things more or less back as I found them and alerted someone that someone who knew more than me had better have a look at the router.

So, I don't know if anybody has had a look at it but now 2 of us can again connect to the internet. I had a look at the router settings last week and I really couldn't see what might be creating this issue.

What might be the problem?

Edit May 19: So today I got there and had no internet access. Somebody else in the building with a laptop did. By the end of the three hour class, I did and he didn't. So I'm guessing it has to do something with IPs. I'm thinking either two people are getting assigned the same IP or IPs are getting assigned that somehow don't route to the internet. Of course I could be (and likely am) way off base. I know not much about networking...

Edit: bump.

share|improve this question
    
Do they get ip addresses assigned, or "limited or no connectivity"? Can you post the result of a "tracert google.com" and "tracert 8.8.8.8" please? –  RJFalconer Apr 21 '10 at 20:51
    
IP addresses are assigned. Tracert of of google.com gives Unable to resolve target system name google.com. 8.8.8.8 gives timeouts for 30 hops. –  Nathaniel Apr 21 '10 at 22:05
    
can you give the results of an ipconfig or ifconfig? –  Andy Jun 16 '10 at 11:42

2 Answers 2

up vote 1 down vote accepted

Last week I tweaked around the network settings on the router ... and even moved the internet cable on the router from port 1 to the internet port.

It sounds to me as though you are approaching this LAN as though it were a typical, very simple, home LAN. I think it is more complicated than that and "tweaking" the router you have physical access to will not help you.

If the (single?) ethernet connection to the router is not connected to the WAN port but to one of the LAN ports then it is most likely being used only as a Wireless Access Point (WAP). If this is the case then it's function is to allow wireless devices to "bridge" connect to the larger wired (& wireless?) LAN of this business.

Normally the DHCP function of a router being used as a WAP should be turned off. I hope you did not enable DHCP on that WAP because that would probably break things. Though I think it could be one possible explanation for why some wireless clients might "work" and others "don't work".

The problem is also likely to be located in another part of the configuration of the LAN you are using. If you are using Windows 7 (or Vista??) you could always try to use the "See full map" function to get a graphical picture of the LAN. I don't know if this will help solve your problem but it would help you discover how big the LAN is.

Hindsight: It occurred to me you might also find something useful in one of the answers to this question: Visual Network Topology Map?

I know not much about networking...

If you were able to gain not only wireless access but also Admin access to this WAP/router, then frankly the person who is supposed to be running this network also doesn't know much about networking ... :-( Un-freaking-believable.

share|improve this answer

Not much to go on.

If it's affecting some users and not others it's nothing to do with the cable.

Possible causes;

  • MAC filtering
  • Router recently changed wireless type to something the cards on some of the clients don't support
  • Client IP lease has been increased, and the router has no more IPs to lease
share|improve this answer
    
The lack of IP addresses available via DHCP was the first thing that popped into my head. –  MDMarra Apr 21 '10 at 21:39
    
Yeah I know, sorry I don't have more info, but I don't really know what else to give. Re DHCP and IP addresses, then... could the router assign an IP address that has no WAN connectivity somehow? –  Nathaniel Apr 21 '10 at 22:06
    
Yes. The router is just a DHCP server. It will still happily assign IPs and direct traffic internally even if there's no internet connection. However if it is not assigning an IP (as is the case here if you get "limited or no connectivity" warnings) then you will not get internet even if it does have WAN connectivity. (This is the case if the router's ip lease table is full. Have you tried resetting the router? as in just power-cycling it?) –  RJFalconer Apr 22 '10 at 21:37
    
Yeah, the router has been power cycled before. I don't really want to touch it now and get blamed for anything... –  Nathaniel May 20 '10 at 5:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.