Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running VMware Workstation 6.54 on a Windows 7 host (64-bit). Whenever the host loses network connectivity the VMs never get their connection back until I reboot the machine (which I have to do right after I finish writing this). I've tried restarting the "relevant" services (like VMware Nat Service) but only a hard reboot works for me. Does this issue sound familiar?

share|improve this question
    
I had a similar problem, but with workstation 10. The solution that worked for me -> superuser.com/a/645401/111219 –  moomoochoo 8 hours ago
add comment

4 Answers 4

up vote 4 down vote accepted

I've had some network "goofyness" with VMware Workstation 7 on Win7x64 but haven't ever had to resort to a reboot.

At the bottom right of the client window are those little status icons. I just right-click on the network icon and select "disconnect." I wait a couple seconds and reconnect it and that seems to get the client back on track.

See if that works for you?

share|improve this answer
    
I'll try this when the situation happens again... –  rasx Apr 23 '10 at 1:12
    
It works for me. –  rasx Apr 26 '10 at 3:35
add comment

Been using Workstation since version 5 and never had such a problem. Recently my host PC's network cable had a problem and the connection was breaking several times a day but I never had even to refresh the guests' connections. You should look somewhere else for the source.

Some points :

Does your guests have the vmware tools installed ?

Did you update your host's network drivers (or did you update them recently causing the problem) ?

Did you play with the network service settings of Vmware Workstation ?

share|improve this answer
add comment

If your question is if this sounds familiar, I have an answer: yes it does. I had to reboot about a dozen times per day. In my case it turned out to be a Citrix client installed on the host. Once I got rid of that, my VM never lost its connection again.

share|improve this answer
add comment

reconnecting the network in each guest didn't work for me. I found a solution on the vmware community site about needing to restart the vmnetbridge service.

http://communities.vmware.com/message/1081585

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.