Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I lock the screen on my USB Ubuntu install be it manually or automatically when I get back it just shows the desktop again without asking for a password.

How can I enable the password lock again? This way it's quite useless.

Thanks for your time.

share|improve this question
    
do you have automatic login enabled (not on the screensaver/lock, i mean when the system first boots up)? –  quack quixote Apr 22 '10 at 9:30
    
This might help: superuser.com/questions/111954/… –  Richard Apr 22 '10 at 11:32
    
@Quack: I have disabled the autologin, and have a password set on my own account @Richard: Will take a look –  Xeross Apr 22 '10 at 12:20
    
Just checked, have gnome-screensaver running, and I don't want to switch as it should work just fine, trying to figure out what's wrong. –  Xeross Apr 22 '10 at 12:22
    
i wrote up this answer for a guy looking for passwordless logins on ubuntu. if i were you i'd check PAM settings for sanity. same guy asked another question in which i did some digging around on how the screensaver lock works -- that stuff about DBus didn't end up helping him but maybe it'll point you in the right direction. –  quack quixote Apr 22 '10 at 12:43

1 Answer 1

up vote 0 down vote accepted

I guess this is just a bug in the usb version of ubuntu, finally have a laptop so no need for ubuntu usb installs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.