Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm setting up a new D-Link N300 router, and trying to connect a MacBook Pro and a MacBook, both running OS X 10.6.

As the question says, either computer can connect to the internet when connected to the router via Ethernet. And either one can get on the router's wireless network. But when connected wirelessly (without the Ethernet cable plugged in), neither one can get online.

I can't figure out why that would be. Any help appreciated.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

How have you verified that "either one can get on the router's wireless network"? Things to check:

  • Check your wired and wireless connections for how they acquire their IP address -- is one or the other configured to use a static/manual IP address vs DHCP assigned IP address?
  • Are you sure you're connecting to the correct wireless router?
  • Plug in the ethernet cable and turn on the wireless. In a Terminal window, run ifconfig en0 (wired connection) and ifconfig en1 (wireless). Are the IP addresses in the same block?

Next steps after verifying that stuff:

  • Is it a DNS problem? Check that your wired and wireless connections are using the same DNS servers. With each connection enabled, look at the contents of /etc/resolv.conf. If they're different, that could be the cause.
  • Do you have custom routing set up somehow for wireless? Compare the output of netstat -r when you're on wired vs wireless connection.
share|improve this answer
    
Many thanks for your assistance—It was different DNS settings, as it turns out. –  Gabe Apr 24 '10 at 13:19

Reboot your cable modem.

You didn't mention how you're connecting to the internet but if you're connecting using cable or DSL, try rebooting all the pieces.

It sounds goofy because you're able to connect using ethernet but...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.