Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been using rsync on OS X to sync all our website admins. It was working fine until the OS X 10.6.3 update!

Now it creates thousands of empty (0-kb) folders. It only does it when synching to a mounted network drive (which we need to do) as when I sync to my local drive it works as usual!

I've tried excludes which don't seem to be working... also tried a different version of rsync so it's an OS X issue.

echo ""
echo "~*~*~*~*~*~*~*~*~*~*~*~*~*"
echo " SYNCING up KINEMASTIK"
echo "~*~*~*~*~*~*~*~*~*~*~*~*~*"

/usr/local/bin/rsync -aNHAXv --progress --exclude-from 'exclude.txt' /Volumes/Groups/Projects/483_Modern_Activity_Website/web/youradmin/ /Users/dan/Dropbox/documents/WORK/kinemastik/WEBSITE/youradmin/  

echo ""
echo "~*~*~*~*~*~*~*~*~*~*~*~*~*"
echo " SYNCING up CHRIS BROOKS YOURADMIN"
echo "~*~*~*~*~*~*~*~*~*~*~*~*~*"

/usr/local/bin/rsync -aNHAXv --progress --exclude-from 'exclude.txt' /Volumes/Groups/Projects/483_Modern_Activity_Website/web/youradmin/ /Volumes/Groups/Projects/516_ChrisBrooks/website/youradmin/

Has anyone experienced the same problem?

share|improve this question

migrated from stackoverflow.com Apr 23 '10 at 11:15

This question came from our site for professional and enthusiast programmers.

1  
What are the N, A and X flags for ? I don't see these listed in man rsync on Mac OS X 10.6.3. Try just rsync -nHv... – Paul R Apr 23 '10 at 10:38
    
I'm having the same problem, using flags -arpV. The rsync was working the first time I ran it, but I hit a an error on a file. I deleted that file and restarted it and ever since then, it doesn't seem to do anything except for create those .DS_STORE files. – Brian Deterling Jan 30 '11 at 2:35

Broken rsync command syntax? A quick check of the man file on my machine (10.6.3) shows:

   --exclude-from=FILE     read exclude patterns from FILE
share|improve this answer

I know this is an old question but I recently had the issue, found the answer elsewhere (http://hintsforums.macworld.com/showthread.php?t=116751), and wanted to share it.

Apparently it happens b/c rsync attempts to create a temp file to which it copies the file before it renames it. The temp file name is in the form of ".{filename}.{some unique id}". Since the file is ".DS_Store" it creates "..DS_Store.{some unique id}". But it seems OS X has trouble w/ files that start w/ ".." so rsync fails quietly and tries again (repeat ad nauseum).

The solution is to ignore the .DS_Store file.

People have also had trouble deleting these ..DS_Store.{some unique id} files. To delete them run:

find . -name '..DS_Store*' -print0 | xargs -0 rm

ETA:

The command above to delete the files didn't end up working for me. I had to move to my Windows machine (which is connected to this external drive via an Airport Extreme) and delete the files. I imagine mounting the drive directly to my Mac via firewire would've also worked.

share|improve this answer
    
By ignoring you mean what @JRobert suggested? Or how do you ignore? – Daniel Beck Mar 31 '11 at 5:25
    
Yes, what JRobert suggested. And for the record, the cmd to delete the ..DS_Store files ended up not working for me. I'll edit my answer to reflect that. – pcg79 Apr 18 '11 at 16:30

Happens to me too. I havent tried it yet but a temporary fix is to exclude all invisible files, at least according to a post on the subject in Apple's Discussions.

http://discussions.apple.com/thread.jspa?threadID=2398971&tstart=60

share|improve this answer

As I recall you can stop that behaviour easily with Onyx: there should be (in one of the last tabs) the possibility to disable the creation of DS_STORE files to remote computers.

alt text

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .