Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My download speed got crazy since I changed the router's IP. But nothing got fixed after doing a factory reset.

The speed was 1024 kb/s (128 kB/s) but it is 200kb/s (max) right now. I mean it works good if a request is small (i.e. a HTTP request) but it gets slow if a request has a big response.

image

Help me please. (It is three days I'm downloading VS2010.)

share|improve this question

migrated from stackoverflow.com Apr 23 '10 at 14:04

This question came from our site for professional and enthusiast programmers.

    
Do you have Time Warner? ISP's have started to give high bursts of speed for a short time at the start of a download. The only thing this does is cause online video to buffer faster so you dont wait as long for the video to start. Also, What speed are you signed up for with your ISP? –  Tony Apr 23 '10 at 14:01
    
Did you changed only its IP or some other settings? What is your router model and what firmware version are you using? –  Ivan Petrushev Apr 23 '10 at 14:08
    
@behrooz: posting on SO and asking for migration is an abuse of the system. continuing to do so is a good way to get your account suspended. you can include image links in comments until you get enough rep to include them in your posts; there are plenty of users here who can edit them into your posts for you. –  quack quixote Apr 23 '10 at 14:13
    
@quack quixote♦:i hadn't enough rep to post an image here. –  behrooz Apr 23 '10 at 14:47
    
@Ivan Petrushev:TP-Link TD-8811 and latest firmware. –  behrooz Apr 23 '10 at 14:47

2 Answers 2

You should try changing your router MAC Address. In the router settings there should be a button to let you clone your computers MAC address. I've heard several accounts where this change has increased speed greatly.

share|improve this answer

Try Disable (turn off) the Firewall of the router. It can solve many speed related problem. Also turn off router at night or at non usage times to save the over heating of the router. Overheated router usually hangs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.