Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Awhile ago I changed the switch port key to left control on my IO Gear USB Switch and I'd like to change it back to Scroll Lock. When I did this, I have some memory of believing that I had found an error in the documentation for the switch regarding how to enter Hotkey Mode.

Per the instructions in the manual(PDF), I'm supposed to be able to enter Hotkey Mode by Holding Scroll Lock for 2 seconds, adding Minus on the keypad for one second, and then release Minus first and within a second release Scroll lock. Ignoring the strangeness and fragility of this process, I'm looking for confirmation that this indeed works for anyone else. I can't remember why I thought it was wrong but I clearly remember that I did (I even had a blog post that I was going to write about but it got lost in the sands of time).

As an aside, I'd be interested in seeing if there is any way to force a reset for the switch without entering Hotkey Mode as that would do exactly what I'm trying to do and I wouldn't have to mess with Hotkey Mode.

Thanks in advance!

share|improve this question
up vote 2 down vote accepted

Hey, I just figured it out. Hold Num-lock down for at least two seconds; then quickly press and release '-' and release num-lock. No 1-second waits like the manual says.

(Your question says 'scroll-lock' where I believe it should be 'num-lock'.)

(edit:) actually, on mine I don't have to even wait the two seconds -- just do the sequence quickly and it works.

Caps lock & scroll lights will flash alternately to let you know you're in hotkey mode.

Once in hotkey mode 't' will toggle between use of scroll lock & ctrl double-taps for port switching; 'r', then 'enter', is supposed to reset to factory config. Either way, hotkey mode is automatically exited.

Thanks for your question -- it inspired me to stop trying to do it exactly the way the manual said!

share|improve this answer
Is there anywhere we can meet so I can give you a big hug!? LOL. Really, though, thank you so much. It worked like a charm. – Tim Visher Jun 21 '10 at 14:31

rw reedy's post actually helped me. The no need to hold '-' for 1 second did the trick however there is also another trick.

So to summarize:

  1. Hold Num-Lock down for at least 2 seconds.
  2. Quickly press and release '-' (no need to wait 1 second).
  3. Quickly release Num-Lock (within the same second as step 2).

But... this might not work for you because:

At the bottom of the KVM, there are icons for mouse and keyboard. If your keyboard/wireless desktop isn't plugged into the USB slot w/ the keyboard, the KVM actually doesn't track any of the hot keys (including CTRL,CTRL).

  • Plug your keyboard/desktop combo into the KEYBOARD USB slot (the one on the right when the port is facing you and the lights are up).

I discovered this on my Logitech EX110. I plugged in a wired keyboard to remap the CTRL,CTRL computer switch toggle, but it would only work on the 2nd wired keyboard and not the Logitech. When I swapped it over, both the Hotkey mode and the switch toggle both work.

share|improve this answer
ahh, I had the keyboard and mouse in the wrong ports – Collin Anderson Feb 21 '14 at 16:26

Thanks, all, for the tips. A couple more:

  • This procedure worked on my mini keybd that does not have a dedicated numlock key; that is, I was able to enter Hotkey Setting Mode (HSM) by holding fn+numlock then pressing and releasing the minus sign.
  • When you're in HSM, the capslock and scroll lock lights on your keyboard (if it has them) will flash in alternation.
  • Note that the hotkeys on this KVM work differently than on older 2-port IOGear models. I kept hitting ctrl-ctrl and expecting the KVM to switch focus to the next port, like my old IOGear 2-port KVM did. Nope, its ctrl-ctrl ENTER!
  • This extra keystroke enables you to switch directly to Port N by typing that number before hitting Enter. E.g if you are on Port 1 and want to go to Port 4, you don't have to type Ctrl-Ctrl Enter three times. just type ctrl ctrl 4 enter.
share|improve this answer

You can also modify a pair of USB extension cables with a switch to alternate the +v, connect the -v, and disregard the data. I did this to switch between my HTPC and my 360 and it works great. You can use relay and remote setup if you want to get fancy.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.