Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In OS X 10.6, Finder usually looks something like this:

alt text

The Finder window looks like that when you double-click on most folders or drives. However, whenever I mount a Truecrypt Volume and double-click that, it looks like this:

alt text

Is there any way to default to the first view option for all types of folders? I tried view options in Finder, but it didn't seem to work.

share|improve this question
    
Knowing the name might help find a solution: clicking the toolbar control button toggles the so-called spatial file manager, aka spatial Finder. –  Arjan May 11 '10 at 17:48
    
Does defaults read com.apple.desktopservices give you any output? (Maybe you've set DSDontWriteNetworkStores but I'd not expect that to affect a local volume.) –  Arjan May 13 '10 at 7:23
    
@Arjan, the result from Terminal is Domain com.apple.desktopservices does not exist –  trolle3000 May 13 '10 at 13:18

6 Answers 6

up vote 3 down vote accepted
+100

Your truecrypt volume is not formatted as JHFS+ (and it won't be). I usually format my tc volumes at fat 32. The easiest work around is to select the truecrypt icon from the left hand side of a finder window that is already open.

Even if you get preferences set for the session that the volume is mounted you will start with the simple finder style folder the next time you mount the volume and double click on it from the desktop.

share|improve this answer
    
I'm not sure what you're suggesting here? I have a FAT-32 partition (filesharing with Linux) that's auto-mounted when I open OSX, and that doesn't show up in 'Spatial Finder Mode' –  trolle3000 May 12 '10 at 14:21
    
... but I DO have an JHFS+ formatted volume that doesn't show in 'Spatial Finder Mode.' Interesting –  trolle3000 May 13 '10 at 14:42
    
I know that fat32 is supported in JHFS+ but I don't know how truecrypt is managing this. For example, look at the terminal and do ls -l /Volumes. You will see your volume. Then do df -h and you will see a different path. Mine looks like: /private/var/folders/4U/4UPMrNiWE8CasZbClZe49k+++TQ/-Tmp-/.truecrypt_aux_mnt1 In that folder is a binary control file and a volume.dmg file ... hmmm –  Sable May 13 '10 at 18:44
    
Closest answer; it definitely has something to do with the formatting –  trolle3000 May 14 '10 at 9:28

I'm not sure if you can set this to default, but to make it look like the first, click the small, pill-shaped button in the top right corner. Hope this helps!

share|improve this answer
    
Yes - Mr. Man is correct. Click that pill-shape button and it will show the normal finder view –  fady Apr 23 '10 at 18:36
    
@Mr. Man, this works - thanks! However, when the folder is closed and reopened, it's back 'like in the lower picture' again. Any way to set the default view option? –  trolle3000 May 9 '10 at 15:03

Based on "Explaining the Finder's view options and toolbar visibility", you're expecting the right behavior and the state of the window should be saved in .DS_Store -- at least as the Finder worked in 2003.

My guess is that TrueCrypt is getting in the way here -- maybe for a good reason.

The above article says that the .DS_Store file "is written when the volume containing the directory is ejected". It's possible Finder tries to write the volume after TrueCrypt has closed the encryption channel. If this is the case, then the fix would be for the TrueCrypt developers to fix this (or, if you have the OS X development skills, do it yourself and contribute the change back to the community).

(Update to the latest TrueCrypt version if you've aren't already there.)

Another possibility is that TrueCrypt is deliberately not allowing this change to save to enhance its plausible deniability. Finder may be writing something about this volume to its preferences. If TrueCrypt were to allow this to happen normally, then this trace information wouldn't allow TrueCrypt users to plausibly deny that they haven't used encryption software.

share|improve this answer
2  
So far yours sounds like the most plausible answer: "This currently cannot be done" ;-) –  trolle3000 May 9 '10 at 15:16
1  
Yes, that would be the short interpretation of my long winded answer. Sorry it couldn't be more helpful. –  Doug Harris May 9 '10 at 17:58
    
@trolle3000, but given your comment at Hasaan's anwer: you did have some .DS_Store file, right? After you deleted that, did it come back? And if you delete it again, does it come back when you just move the Finder window? –  Arjan May 13 '10 at 7:12
    
@Arjan, the .DS_Store files did not re-appear –  trolle3000 May 13 '10 at 13:21

Delete the hidden .DS_Store file in that folder

share|improve this answer
    
This didn't work. –  trolle3000 Apr 24 '10 at 9:40
    
Onyx has an option to delete all .DS_store files to reset view settings. –  Kio Dane May 13 '10 at 14:17

Try plugging in the drive then go to Finder preferences at

~/Library/Preferences/

then open the com.apple.finder.plist file. Search down this for a configuration drop down list for the drive. Click "WindowState" and there should be a tick box for "ShowSideBar" tick this and it should work hopefully

share|improve this answer
    
Hi. I can't find any drive-specific drop down lists. I tried to tick all ShowSideBar's I could find, but it didn't work. –  trolle3000 May 13 '10 at 14:23
    
Worked for me after I restarted Finder. Thanks! –  Jason T Featheringham Mar 8 '13 at 5:37

Just like Mr. Man said, the button in the top right corner of the finder will expand your finder to the normal view. If you want to to set defaults for a certain view, right click /cmd click anywhere inside the finder window and you should see an option - view options or cmd +J, both work.

update: Actually - try expanding your finder to show the default layout, as mentioned above, then close and re-open....if im correct, it should re-open in standard view.( could be wrong, @ work on a linux machine, so i cannot replicate it.)

enter image description here

share|improve this answer
    
However, there is no option to do what trolle3000 wants, so it can't be set as a default. –  KeithB Apr 23 '10 at 18:57
    
The close and re-open didn't work - it goes back to icon view. –  trolle3000 Apr 24 '10 at 9:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.