Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a DNS server set up on one of my machines using BIND 9.7 Everything works fine with it. On my Windows 7 desktop, I have statically-assigned all network values. I have one DNS server set -- my DNS server. On my desktop,

 I can ping a third machine by IP fine.
 I can nslookup the hostname of the third machine fine.
 When I ping the hostname, it says it cannot find the host.

/

C:\Users\James>nslookup icecream
Server:  cake.my.domain
Address:  xxx.xxx.6.3

Name:    icecream.my.domain
Address:  xxx.xxx.6.9


C:\Users\James>ping xxx.xxx.6.9

Pinging xxx.xxx.6.9 with 32 bytes of data:
Reply from xxx.xxx.6.9: bytes=32 time<1ms TTL=255
Reply from xxx.xxx.6.9: bytes=32 time<1ms TTL=255
Reply from xxx.xxx.6.9: bytes=32 time<1ms TTL=255
Reply from xxx.xxx.6.9: bytes=32 time<1ms TTL=255

Ping statistics for xxx.xxx.6.9:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Users\James>ping icecream
Ping request could not find host icecream. Please check the name and try again.

I have also specified the search domain as my.domain

  • xxx.xxx and my.domain substituted for security

Why can I not ping by hostname? I also can not ping using the FQDN. The problem is that this problem is shared by all applications that resolve hostnames. I cannot use PuTTY to SSH to my machines by hostname; only by IP

share|improve this question
    
I'm in a similar setup, and forgot at first that I can (as you should be able to) use icecream.local. This works for me because I don't have a domain, but I do have a local DNS server that has internet and intranet name services. –  user68988 Feb 24 '11 at 15:17

6 Answers 6

up vote 0 down vote accepted

You could try editing your hosts file. Put there the hostnames and ip-adresses of your other machines. If thats not working try this: Your Router should be able to handle dns-tables for itself. Try to temporarly shut down your dns-server and clear all dns caches on all machines. Then restart your router and try it again.

share|improve this answer
2  
Your post gave me an idea. I tried ipconfig /flushdns and it started working again. It doesnt make sense though because it was working before then it just stopped. check&+1 for helping. –  Puddingfox Apr 23 '10 at 16:43
    
@Puddingfox Have you found any real cause? I have posted essentially the same question for a Windows XP SP3 computer, with the same workaround. –  Mark Hurd Jun 13 '10 at 5:14
2  
If you put the names into the hosts file, what is the point of having DNS? –  vonbrand Feb 10 '13 at 4:19

Check for firewall settings in your Windows 7 machine. By default, Windows 7 added to a domain turns on the firewall. You can also make a rule to open ICMP in firewall. This will allow these packets to reach your machine and you'd be able to ping it.

share|improve this answer
    
The op could ping the machine by ip just fine. –  Jason C Jul 17 at 18:33

To disable this behaviour, disable Negative Caching by setting the value of NegativeCacheTime to 0 at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ Dnscache\Parameter

share|improve this answer

I'm looking for a permanent solution to this problem. I don't just have a problem with ping icecream, but also ping icecream.my.domain. It doesn't happen all the time, just randomly on one computer. ipconfig /flushdns fixes it sometimes and rebooting work as well, but it's not a permanent solution.

I just tried this:

Based on this:

share|improve this answer
    
If you have a new question you should probably delete this answer and ask a new question instead, linking back here. –  slhck Nov 22 '11 at 22:12
    
I don't have a new question. I have this SAME problem. I'm answering with a possible solution. –  bendiy Nov 22 '11 at 22:14
    
Worked for me :) –  Zsub Nov 28 '11 at 14:14

You don't have DNS suffixes configured. Either configure them, or use FQDN like this and it should work:

ping icecream.my.domain
share|improve this answer

I faced the same problem in my network. When you use this command:

ping icecream

It uses WINS server since you have used icecream not icecream.my.domain.

When looking for such words, Windows looks for NETBIOS names, but when you look for complete domain records, it will look in the DNS server. You can use one of the solutions below:

  1. Make sure you have correct records for that station in your WINS server.
  2. Use the complete domain name instead of using the host file. E.g. icecream.my.domain
share|improve this answer
    
Ping uses the normal Windows name resolution methods. Which means it starts out by checking the resolver cache, the local hosts files, the DNS servers, and eventually will resort to sending out a NetBIOS name query to everything using NetBIOS on the same subnet. –  mazianni Feb 24 '11 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.