Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way of stopping Windows Live Mail client repeatedly asking whether I want Outlook Express [sic] to compact my messages?

[p.s. please don't suggest that I just switch to a different mail client]

share|improve this question
    
same problem here...good question. +1 –  studiohack Apr 24 '10 at 5:52
add comment

1 Answer 1

up vote 1 down vote accepted

Judging from responses found online, it looks like there is a counter in the registry that counts up each time you close Windows Live Mail or Outlook Express. When the counter gets to 100, it prompts you to compact.

If something causes Windows Live Mail or Outlook Express to load itself into memory then close, the counter is incremented. For example, opening a file with extension .EML while WLM/OE are closed will do it. If another program queries your mail information, the same thing could happen and the counter will increment.

You could either go the trial and error route or the diagnostic route try to fix this.

If you want to be diagnostic, then grab a copy of Process Monitor and run it for a while, then search for anything that's hitting the registry key HKEY_CURRENT_USER\Identities\{GUID}\Software\Microsoft\Outlook Express\5.0, where "{GUID}" is your unique user GUID. It will probably be WLM/OE itself that's incrementing the counter in that registry key, but you can see what programs are active immediately before that happens.

If you want to use trial and error route, then it looks like people are blaming any or all of the following:

  1. Windows Desktop Search. Go to Indexing Options and clear the checkbox for Outlook Express.

  2. A particular keyboard driver, RAKDLL.DLL (IBM Rapid Access Keyboard).

  3. Nero Scout. Disable indexing for *.eml, *.dbx, and *.nws.

  4. Various anti-virus or anti-malware programs.

share|improve this answer
    
Of the things you suggest, the Desktop Search is the only really likely one on my system, but I've checked my config and it is indexing my email so I've switched that off. There's an option to "compact every xxx shutdowns" which is switched off in my mail config, but maybe that just switches it to "ask to compact every xxx shutdowns" - I've upped xxx to 999 in the hope that might make things easier too! +1 for your suggestions. Thanks. –  Rob Gilliam May 1 '10 at 12:31
    
4 weeks on and I don't think I've been asked even once yet, so I think you were right with the desktop search suggestion. Accepted answer. –  Rob Gilliam May 30 '10 at 10:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.