Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run Eclipse java-galileo-SR2-win32 when I get open-file-security-warning. The files are just extracted from a zip file and put into a directory "C:\Users\UserName\AppData\LocalLow\eclipse-java-galileo-SR2-win32\eclipse". The interet explorer settings for adding network drives to the intranet zone do not work on local drives. Also there is no option to 'unblock' the file in the file properties. What other option is there to turn off this annoying prompt? Or even better be able to select which files are considered safe to run.

share|improve this question
add comment

3 Answers

In the start menu enter gpedit.msc. Then go to:

User Configuration -> Administrative Templates -> Windows Components -> Attachment Manager

and Add *.exe to the "Inclusion list for moderate risk file types" setting.

share|improve this answer
1  
I want to be able to select which exe are allowed to run, rather than allow all of them. –  Menuta Apr 24 '10 at 9:37
    
@Menuta: Just a long shot, but you try adding "filename.exe" instead? It appears to work for me –  jay Apr 29 '10 at 7:05
    
Thanks for the suggestion, hadn't thought of that, obvious really. I have already moved the files to program files anyway which has bypassed the error. –  Menuta Apr 30 '10 at 7:38
    
Adding eclipse.exe works great! +1 –  KronoS Jan 21 '13 at 16:42
add comment
up vote 4 down vote accepted

The solution is to put the directory where it belongs such as C:\Program Files (x86)\eclipse-java-galileo-SR2-win32\eclipse this the removes the open file security warning dialog. c:\Users\UserName\AppData\LocalLow directory must have similar security as the intranet zone.

share|improve this answer
    
If anyone knows why the LocalLow folder is restricted like this can you please tell us why? –  Menuta Apr 29 '10 at 2:25
1  
That is its sole purpose. Trusted data goes in c:\Users\UserName\AppData\Local, untrusted data in ..\LocalLow. My understanding is that, if a pre-Vista program attempts to write to the users application directory (ie what used to be c:\Documents and Settings\UserName\Application Data) then this is magically remapped to either Local, LocalLow or the Roaming subfolder inside c:\Users\UserName\AppData depending on which mode the program is running in. So if program is running in low security mode , then it can only write to LocalLow which is also low security. –  sgmoore May 1 '10 at 19:45
add comment

Is it possible that one of the other files (maybe a dll) is blocked?

Streams from Sysinternals is a handy command line utility which can be used to display NTFS streams on all files in a directory and sub-directories. It can also be used to remove all the streams (assuming that they are all just Zone.Identifiers)

share|improve this answer
    
I tried that no luck. –  Menuta Apr 27 '10 at 6:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.