Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I prefer the sound scheme of Windows 7 HP to be set to "No Sounds" ALL the time. The problem is, when I switch themes, the themes switch sound schemes also. I know I can go in and disable/change to "No Sounds" every time by hand, but is there a way to turn it off and keep it off, regardless of the theme?

EDIT I want to disable Windows sounds, not application sound.

share|improve this question

7 Answers 7

Been messing around with this myself, simply deleting all the audio-files in the Windows dir of the clients is both the least elegant and most surefire way of accomplishing this. I find it rather perplexing this can't be controlled in a more elegant manner, catering to a silent sound scheme is not exactly filling a niche.

share|improve this answer

Specifically for Windows 7:

The sound files can be found in C:\Windows\Media so just move all the files in this folder into a new folder (e.g. C:\Windows\Media\old).

You will need to change the permissions of the Media folder in order to move all the files because they are by default owned by TrustedInstaller. To do this right click on the folder and go to Properties->Security->Edit->Click on your username and check the box for 'Allow' next to 'Full Control'. You can now move the files wherever you like.

share|improve this answer
  1. Go to:

    C:\Users\yourusername\AppData\Local\Microsoft\Windows\Themes\
    
  2. Open up the specific theme file (e.g. newtheme.theme) in Notepad
  3. Update and save SchemeName to No Sounds:

    [Sounds]
    ; IDS_SCHEME_DEFAULT
    SchemeName=No Sounds
    
share|improve this answer

In Windows Vista and later, you can control per-application sounds, including system sounds. Click the volume icon in the taskbar, then click on "mixer".

volume slider

Click the mute button under "System sounds". Applications' sounds will still play, but system sounds will not.

mute system sounds

share|improve this answer
2  
ah! very true! I had forgotten about that! +1! –  studiohack Oct 13 '10 at 1:08
    
Thanks! Happy to help. Sometimes the easiest solutions aren't readily apparent... your solution was certainly creative, but this would probably be more straightforward for future searchers who find this question. –  nhinkle Oct 13 '10 at 1:11
    
yah, very true...Somehow, recently, the system sounds came back...so I was frustrated, but putting up with it, and found the Sound Sentry option while cleaning out my RSS feeds, so that is my current solution...But yours is even quicker to access and turn on and off... cheers! :) –  studiohack Oct 13 '10 at 1:13
    
Sounds good. Odd that the sounds came back... perhaps system file checker or a windows update replaced them? –  nhinkle Oct 13 '10 at 1:50
up vote 7 down vote accepted

OK, I went to the folder where all system sounds were stored, and moved the entire folder elsewhere, so if it does change system sound schemes, it won't have a source to play the sounds...


The other option is Sound Sentry...In the accessibility control panel, you can choose to have all sound disabled and, optionally enable visual cues instead.

From Online Tech Tips:

http://www.online-tech-tips.com/windows-7/how-to-activate-windows-sound-sentry/

share|improve this answer
    
I didn't see this question when it first came up, but since you edited, it got bumped to the top again. See the answer I just posted; I think it may do what you're trying to get at, without having to delete/move the system sound files. –  nhinkle Oct 13 '10 at 1:08
    
Note that on Windows 7 the sound files can be found in C:\Windows\Media –  donturner Jan 1 '12 at 15:15

Go to Sound under Hardware and Sound in Control Panel (or just use the Start search), open the Sounds tab, then select the "No Sounds" scheme.

share|improve this answer
    
That doesn't work because when you change theme the sound scheme is changed. –  donturner Jan 1 '12 at 15:11
    
@donturner: You change themes often enough that this is an issue? –  Hello71 Jan 1 '12 at 16:43
    
Yes, the same as OP –  donturner Jan 2 '12 at 0:19

I had the same issue and tried using the "prevent changing sounds" Group policy setting, but whenever you change the theme it would change the sound scheme so that didn't really work.

Deleting or renaming the folder sounds like one way to fix it, but I found that updating the registry to removing the sounds from all of the themes also works. This Powershell script will remove all of the sounds assigned to each sound scheme so that they all are equivalent to the No Sound scheme. (NOTE: you may want to backup the hkcu:\AppEvents\Schemes\Apps registry key first in case you want to recover the sounds later.

$ThemeSounds = Get-ChildItem hkcu:\AppEvents\Schemes\Apps -Recurse | Get-ItemProperty
foreach ($regkey in $ThemeSounds){
    $strVal = [string]$regkey.'(default)'
    if($strVal.EndsWith(".wav")){
        Set-ItemProperty -Path $regkey.PSPath -name "(default)" -Value ""
    }
}

If you change hkcu:\AppEvents\Schemes\Apps to hkcu:\AppEvents\Schemes\Apps\.Default it should only remove sounds for the Windows group listed in the sound settings and not any of the other apps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.