Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been using linux mint 7 for a couple of weeks now and I'm pretty happy with it, but I wanted to try out other desktops, e.g. KDE/Xfce

I'm not sure if it's KDE's fault of Xfce's, but firefox's font rendering sucks now, it renders jagged/aliased fonts.

I'm using xfce right now,

My Xfce settings Manager > appearance > fonts settings roughly look like this:

Default Font:

     Sans | 9  

Rendring :

 [x] Enable anti-aliasing  

           Hinting: None  
   Sub-pixel Order: None  

But it's as if firefox ignores these settings!

share|improve this question
up vote 7 down vote accepted

Try editing your .fonts.conf file under your home directory (~/.fonts.conf).

This works well for me:

 <?xml version='1.0'?>
 <!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
 <fontconfig>
  <match target="font" >
   <edit mode="assign" name="hinting">
    <bool>false</bool>
   </edit>
  </match>
 </fontconfig>
share|improve this answer
    
Awesome! this worked for me too, thanks! – hasen Jul 27 '09 at 4:23
1  
Yeah, I find fonts.conf sort of overrides pretty much everything else, so I always look to it first for font problems. Glad it helped! – John T Jul 27 '09 at 4:25
    
Careful, there is a space in the code above, make sure there is no space before the first opening bracket (check if you get Fontconfig error: "~/.fonts.conf", line 1: XML or text declaration not at start of entity error on running fc-cache after adding this file). – ABerezovskiy May 13 at 22:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .