Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I increase performance of Remote Desktop on windows XP sp3? A better network connection is not an option, this is for at work. I have suggested a network upgrade to my boss and it is not in the budget right now, but I need to access my home computer and right now it is somewhat unusable.

share|improve this question
I have fiber optic connection at my house and downloads easily go 1mb/sec and higher, so i don't think so... – H B K Jul 27 '09 at 6:38
If you need to access home computer from work, upload is important. – Marek Grzenkowicz Jul 27 '09 at 7:14

The best way is to simply turn off unnecessary features, and tone down the others.

With Remote desktop open, click the [ Options >> ] button:

alt text

The window size will increase and you will see a number of tabs as shown here:

alt text

These are the main tabs to look at to increase your performance:

The "Display" tab

You can decrease the size in which you will view the remote desktop in this tab. Lowering this greatly improves performance, just make sure you can still read text and see what you're doing.

You can also change the color detail in this tab, If you are simply viewing text, 256 colors is fine, else try 15 or 16-bit if 256 is too low for you.

The "Local Resources" tab

The only main bandwidth eater in this tab is the remote sounds. If you do not need to hear sounds from the remote computer, I'd suggest turning this off altogether.

The "Experience" tab

In this tab I'd suggest unchecking every checkbox except for "Bitmap caching". Bitmap caching will download images that you will see most often such as the start menu image or system tray, and save them locally to your PC. For a low bandwidth user this is beneficial, as these "chunks" of the screen are not resent each refresh.

share|improve this answer

I know this is an old topic, but for others, in your RDP file make sure this line is set to 1:


You can do this from the UI, but then add this magic line too:


This will max out your bitmap cache so you request bitmap data less frequently.

share|improve this answer
bitmapCacheSize:1:32000 is precisely what I needed! It raises the bitmap cache from 1.5MB to 32MB. Now switching between browser tabs with graphics is a lot faster. MSDN's list of rdp file options – netvope Dec 22 '11 at 9:32
FYI for readers unfamiliar with an RDP file: it is created when you click that Save As button while looking at all the available Options for the connection. – sfuqua Feb 27 '13 at 15:00

Disable visual styles, set a solid color background, etc ; go to My Computer properties -> Advanced -> Performance Settings, and select adjust for best performance.

share|improve this answer
this is not a problem if you tweak the settings like John T mentions – pavsaund Jul 27 '09 at 8:46
Interesting. Some people on neowin found instead that enabling both Desktop Composition and Visual Styles actually helped their performance. – gmatht Jan 27 '15 at 15:23

You might want to consider using a remote desktop application that does all of the above for you.

GoToAssist from Citrix will actively reduce the data being sent by optimizing the image. You can try it for free. Works well for anything down as far as a 512Kbit / 128Kbit ADSL connection

It can be quite restrictive as to what you do on the PC you're remoting in to. For example, in Vista, any network connection properties cannot be touched remotely. There may be a way around this but I'm not sure of it.

I've only used it from a support point of view but for what it does, I think its pretty ingenious

share|improve this answer

Lowering the color isn't helpful. See ** **

share|improve this answer
Hi Eric, welcome to Super User. Can you summarise why lowering the colour isn't helpful? Answers that are either solely (or mostly) a link are discouraged here. – bertieb Aug 10 '15 at 18:05

A major factor that hasn't been mentioned yet is the hardware installed on the computer. It doesn't matter if you have a fiber optic connection if the hardware on the computer cannot handle the incoming/outgoing information fast enough. This bottleneck usually takes place in the ethernet adapter/network card. Many older XP machines and many laptops, even new ones, do not have the ability to make full use of high speed connections. This is because the network adapter is usually maxed out at 100mbit.

To put that into perspective, 100megabits per second is 12.5 megabytes per second, not taking into consideration including any overhead on the network, host/remote PCs, and any traffic on the larger internet.

Optimal speeds can be achieved by pairing a gigabit ethernet card with a router/switch that can also handle the gigabit standard. This improves the speed to a maximum of 1000mbps (~1gbps) or 125 megabytes per second. You can learn more about the speeds and standards by reading this article on it.

share|improve this answer

You must log in to answer this question.

protected by bwDraco Sep 9 '15 at 20:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .