Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My netbook OS is Windows XP Home Edition SP3. My wireless network option shows WPA/WPA2 option when I select it, it connects to the router but no internet access. Then I changed my router settings to WEP and configured my netbook and it works fine. I want to use WPA2 security. Please could anyone help to fix this issue?

share|improve this question
    
router make/model/firmware version? netbook make/model? NIC make/model/firmware version? need more info bro –  BroScience Dec 27 '12 at 14:04

2 Answers 2

Connect to your wireless router then open the network status page for your wireless connection (Control Panel > Network Connections, double-click your wireless connection). Then open the Support tab and click Repair. Wait until Windows completes the entire repair process.

If 'repair' does not solve the problem, open the properties dialog for your wireless connection (Control Panel > Network Connections, right-click your wireless connection and click Properties). Now open the Wireless Networks tab. Under Preferred Networks, double-click your wireless network. Make sure that the option selected for Network Authentication and Data encryption match your router settings.

Finally, if none of the above solves the problem, try upgrading the driver for your wireless network adapter.

share|improve this answer
    
While you are at it, Right click on My Computer and select Properties. Once you are in there, go to your Device Manager. Find the wireless card driver and uninstall it. Reboot after the driver is uninstalled. Then let windows reinstall the device. –  xxl3ww Dec 27 '12 at 14:29

Are you running MAC adress filtering on your wireless router? If so, check the properties on the wireless card in your netbook, and make sure that the network adress value on the Advanced tab is set to the mac adress of your wireless card, and not set to "Not Present". That was the problem I had with me eee pc. I got the correct mac adress for my wireless card by running ipconfig /all at a DOS prompt.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.