Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I presume this is a better place to put this rather than server fault.

I'm interested in setting up a small site to host at home as a "proof of concept" exercise, i.e. to prove that I know how to do it. I've got a (virtual) server 2003 machine with a site on it, all configured with port forwarding through to 80 on my server. I have a Belkin F5D7634 which I have put my DYNDNS details in but when I try to go to my DYNDNS address it comes up with the page cannot be displayed.

My ISP is Carphone Warehouse/AOL and I've been unable to find any information if they block port 80. If they do, can anybody recomend a home provider that does not block port 80?

share|improve this question

3 Answers 3

up vote 4 down vote accepted

More ISP's than not will block port 80 nowadays to prevent incoming traffic. Usually they won't tell you they are blocking it and your odds of getting a straight or accurate answer if you call tech support are about 50/50. Some ISP's will allow you to set up a server if you work with them to set it up (sometimes with additional monthly fees, sometimes not). About the only way to find out is to call the various ISP's that serve your area and see what they say. Oh, and call the tech support number, not the sales office. The salespeople will either have no idea or they will just tell you what you want to hear.

share|improve this answer
3  
The only thing I have to add is that you should try forwarding to and running the server on a different port (e.g. 8000) and connecting to that one instead. If it works, you know that port 80 is special, i.e., blocked. –  marcusw Apr 26 '10 at 18:10
    
+1 for the call tech support idea, much appriciated. –  tombull89 Apr 30 '10 at 14:35

I'm going to reply to this as I've now found the answer.

The problem was with the port forwarding of the router. Due to a bug in the firmware, it would only "remember" the TCP port setting, even when changed to UDP/TCP or just UDP. Following a firmware update I can choose to forward both types of port and it seems to be working. I am surpirsed that the ISP doesn't block port 80, but hey, I'm not going to complain.

share|improve this answer
    
A web server will use only TCP port 80. You shouldn't need to forward UDP as well. –  jmbouffard Jul 19 '11 at 12:22
    
@jmbouffoar this was before I knew about only using port 80 TCP, but thanks for adding the comment. –  tombull89 Jul 19 '11 at 12:30

For testing, take DynDNS out of the list of possible problems:

  1. Go to whatismyip.com.
  2. Try that IP address directly, but: from some other internet connection, like by using Web-Sniffer.
  3. Try an online traceroute to that address (that will not use port 80, but might still give you some clue).

If that doesn't work, there are many possible causes other than port blocking, like:

  • Maybe the port forwarding in the router is incorrect.
  • You might be trying to use the DynDNS address (or public IP address) from within your own network, which will likely end up in your router rather than at the web server.
  • Maybe (but not likely) you've set up your web server to only bind to localhost, not to any outside requests.
share|improve this answer
    
"You might be trying to use the DynDNS address (or public IP address) from within your own network, which will likely end up in your router rather than at the web server." The DSL router's I've used do this. If this is the case, use a proxy/someone else's line to get past it. –  Henri Watson Apr 26 '10 at 22:09
    
@Henri, or use Web-Sniffer and the like to test that (either with the IP address, or with the OpenDNS name). –  Arjan Apr 26 '10 at 22:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.