Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I am trying to secure empty my trash, I get a dialogue box saying:

The operation can’t be completed because you don’t have permission to access some of the items."

share|improve this question

By the sounds of it you don't ownership or read write permissions of the file(s) you are trying to delete, check in the trash, see what files are remaining.

Go to trash highlight the files the remain, press cmd + i, check the permissions, if you know the password to the admin, or the account that owns said files press the padlock in the righthand corner, and add read write permissions for your user, then try and delete again.

share|improve this answer

If you do not have access to an administrator's account, go into Terminal and type the following command:

rm -rf ~/.Trash/*

If you're wondering what that command does, it simply "force-empties" the Trash by using the rm -rf command.

Another way to empty the Trash is to hold down the "option" key while emptying the trash like you normally would.

share|improve this answer

Since I'm not a programmer, I don't do anything through the Terminal because I'm afraid I'll screw something up. I had my trash collected into a "trash" folder to dump all at once.
Tried the read / write permissions through Get Info, even locked & unlocked the folder & then tried to empty trash- still didn't work.
Then I put the folder back (it was on a flash drive) then made a blank folder with the same name-"trash" on the desktop.
I copied that folder to the flash drive, which overwrote the "trash" folder on the FD. Then I put that in the Mac Trash can & did Secure Empty Trash- it worked!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .