Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have several other machines that are on other operating systems (XP, etc.) and they show up just fine on other machines NOT running Windows 7. However, they do not show on the Windows 7 "Network" area. I can directly access them by typing the computer (\\mycomputer), then they show up on the list. However, they don't stick around and when I close Windows Explorer and open it again, the computer is not listed again in Network. There was never a problem using Windows XP where all the machines showed up just fine. This is not an access problem but a listing problem.

share|improve this question
1  
have you checked the name of the workgroup? maybe the win7 machine has got a different one. –  Diskilla Apr 26 '10 at 21:28
    
Are you asking for the reason why it is like that, or for a solution, how you could make each computer show up on the others network listing? –  Kissaki Jun 12 '11 at 12:29

7 Answers 7

up vote 2 down vote accepted

Just check your windows firewall.. disable it then check that network PC's are showing or not.

Other sol:- In windows 7 there is option for network to chose that it is "home", "work" or "public" network. Just go network from bottom right corner of your task-bar n/w icon and change the n/w to HOME or WORK n/w.. i think you problem will be solved.

At last if not solved then disable your antivirus firewall and check.

share|improve this answer

On Windows 7, go to Network and Sharing Center, change Advanced Sharing Settings.

Turn on network discovery for whichever network you're connected to (i.e. home, public, domain). Although I wouldn't recommend you turn it on if you're on a public network.

share|improve this answer

This is something I've encountered before, XP not showing vista/7 machines. There's a kb article on Microsoft which gives you an installer so XP will "see" the new OS's. I think it's called LLC but i'm not 100%, if need be I can send you the file.

share|improve this answer

Windows Vista/7 have a different network discovery protocol, especially the homegroups concept. That is why they don’t show up in each others network. But as the network discovery does not influence actual network you can still access it directly.

share|improve this answer
    
Vista/7 still support and use NetBIOS network browsing. –  grawity Jun 12 '11 at 13:00
    
So it discovers and displays them by default? –  Kissaki Jun 12 '11 at 13:17
    
Not sure about "by default" - I think the "Network discovery" has to be enabled manually. But it toggles both protocols, LLMNR and NetBIOS, as a single feature. –  grawity Jun 12 '11 at 18:26

When I had the problem, all I had to do was open the network and sharing center (through control panel or right-click the wireless network bars at the lower right and select "Open Network and Sharing Center"), then click "See full map" at the upper right. That seemed to force Windows to update the network and everything worked great after that.

share|improve this answer

After many hours of troubleshooting, I found that after changing each computer on the network from the default WORKGROUP to a different name, they all started to work.

share|improve this answer

Have you tried Mapping the network drive? I know that this isn't a direct fix, but it still gives the access to the drive. You map the network drive the same way you directly access the remote PC.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.