Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with PuTTY (a terminal emulation program). After connecting to my unix box from putty bash completion does not seem to work .

Does anyone know a plugin that can help me or another terminal emulator that can achieve these feat.

share|improve this question
add comment

migrated from stackoverflow.com Apr 27 '10 at 12:09

This question came from our site for professional and enthusiast programmers.

4 Answers

Tab completion is provided by the shell you're running on the Unix server, not by PuTTY itself.

To see what shell you're running, try:

echo $SHELL
share|improve this answer
add comment

If bash completion is not working, it can not be a PuTTY setting. This has something to do with a setting in your target server. Are you sure you are on bash?

Also, try adding

if [ -f ~/.bashrc ]; then
        . ~/.bashrc
fi

or a call to /etc/.bashrc in your .bash_profile

share|improve this answer
add comment

Does 'TAB' work in other contexts? That is, can you use putty to connect, then open an editor like vi or emacs, press TAB, and have it do something? If 'TAB' does something over putty in an editor but not shell completion then it's not putty, it's a configuration on your server.

share|improve this answer
add comment

Does the value of $TERM correspond to PuTTYs terminal setting? Does PuTTY send the proper keyboard mappings to the Unix host? Does the character set of your Unix session match the character set of your PuTTY terminal emulation?

You can adjust these settings in the Connection->Data, Terminal->Keyboard, and Window->Translation panel in the PuTTY configuration dialog, prior to running your session.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.